Jump to content
The Klipsch Audio Community

ezmoney68

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ezmoney68

  • Rank
    Newbie
  • Birthday 11/30/1968

Profile Information

  • Gender
    Male
  • Location
    Oklahoma
  1. There must have been a huge issue with the Sony amp. I hooked up the old NAD and the speakers sounded perfect. If it was an amp issue, the woofers may have not been blown on the original speakers after all. Oh well, new setup and system for the bedroom now as well. Thanks for all of the help!
  2. The current receiver is a Sony DA5400ES.
  3. I will have to get the number when I get home
  4. This forum provides a wealth of knowledge and I want to thank everyone for their input. I apologize in advance for this lengthy story, but hopefully some of you can relate. My first nice system in 1988 consisted of a pair of Quartet speakers and a NAD integrated amp with a NAD 6 disc cd changer. I remember the day the salesman played those speakers and it felt like someone was standing there thumping my chest! I was hooked. Over the years, I added a Klipsch sub, center and surrounds for the home theater experience with my Pioneer Elite 65" TV and upgraded to a NAD T770 receiver. I could blow the windows out of the house with that system. After a divorce, a move into a different house and an upgrade on some technology, I find myself puzzled. I purchased a new TV and blue ray player. Of course my old components did not have HDMI imputs. Normally, I do extensive research before purchasing anything, but a big orange "SPECIAL" sign led me to purchase a Sony ES 7.1 channel home theater receiver with more inputs/outputs than the space shuttle. The ease of connection, reduction in wires, and advertised superiority of the HDMI was attractive to me. With the new house and extended hours at a new job, I rarely exploited the system. While I was out of town, an unexplained incident with a house sitter or teenaged son seemed to blow all the woofers from my system. Out of frustration, I let the system sit idle for quite some time. After a windfall, I decided to treat myself to some new speakers. The whole home theater set up has lost its appeal to me......and what I really enjoy is listening to my music. With this being said, I moved the surround set up to the master bedroom with the intent of reconing the woofers eventually and ordered a pair of Cornwall IIIs for my TV/Listening room. I was as excited as a little kid at Christmas as I slid those speakers out of the box. (My wife was a little less excited when she saw the size of the Cornwall IIIs, but that is another story.) Here is where I need the forum's help. When I hooked up the speakers and played a few CDs, I was pretty underwhelmed. I chose not to biamp the speakers initially because everything I read seemed to be split down the middle whether it was beneficial or not. I was being cautious at first with the volume, especially after the blow out of the previous set up. I carefully increased the volume and the sound was crisp, with no distortion or hiss, but the sound just seemed flat. This receiver has the microphone that you position so that it takes measurements of the room etc and I went through all those steps. I even went in to the digital equalizer and increased the bass levels, which helped round out the sound somewhat. After these adjustments, I increased the volume, but nowhere near pissing off the neighbors levels and the left speaker started to pop. I turned down the volume as quick as I could, but it had popped about three times. Do you think the receiver has an issue from the previous incident? Is it not good enough to drive this speakers? My old NAD equipment had no issues driving my speakers and I had researched its quality. Is a lack of power to the speakers causing the popping? Is that popping referred to as clipping? Since I do not care about the surround sound and am going to a 2 channel set up, would biamping give more power to the speakers and eliminate this issue? Any advice is welcomed and I appreciate everything in advance.
  5. I am a long time fan of Klipsch speakers. I am upgrading from a set of 1988 Quartets. I purchased a set of cornwall 3s today. I have decided not to bi-amp at first, but I have a question. I have a set of banana plugs on my speaker wire, but the terminals on the back of the speakers seem to have a cover on the terminal preventing me from inserting the banana clips. I have not bought any speakers in 25 years and have not encountered this before. Any help would be appreciated.
  6. I have a set of Klipsch Quartets that I bought new over 20 years ago. Along the way I added a powered sub, center channel and surround speakers that were close to the best that Klipsch offered at the time. Recently, a teenage individual somehow managed to blow the woofers in the quartets as well as destroy the sub. I also noticed a hiss possibly coming from one of the midrange horns. I called Klipsch and the put me in touch with a company in Florida that can respool the woofers. My question is, will they ever be the same or am I throwing good money after bad by trying to repair them? Do you think that issues will continue to appear due to the magnitude of the damage? The cabinets are fine as well as the passive radiators. The tech in Florida said it was unlikely that the tweeter or midrange horn suffered any damage, but the hiss concerns me. I assume the the teenager hooked up an ipod or other poor quality source and had the levels all turned up to ten. He has yet to come clean with the details of this adventure, but I am sure that the house was rocking. I can' t really afford to replace the system right now, but would the Cornwall be the way to go when I save my pennies? I haven't had the need to compare speakers for years, but am absolutely sold on Klipsch. Any advice is appreciated!
×
×
  • Create New...