Jump to content
The Klipsch Audio Community

Thrasher

Regulars
  • Content Count

    74
  • Joined

  • Last visited

Community Reputation

20 Excellent

About Thrasher

  • Rank
    Advanced Member

Profile Information

  • Gender
    Not Telling

Recent Profile Visitors

834 profile views
  1. Pmd Sent from my SM-G935V using Tapatalk
  2. Do you have a Frys Electronics up there? I'm in WA, across the BC Border. Once in a while, Frys has the R112sw for $399 USD. got the R115sw for $429 USD. That being said, the R12SW is a better unit, IMO. The 115 fills my 15x20' room with really low slow rumbling bass. I miss the 12sw I was using. It has the well defined and sharp punch that's missing. Sent from my SM-G935V using Tapatalk
  3. I am confused as to why there is rust on the screws. Any ideas? Anyone? Sent from my SM-G935V using Tapatalk
  4. Working on it... Sent from my SM-G935V using Tapatalk
  5. The sound quality and fullness are night and day. The Sunfire is warmer and all around better for my tastes. No comparison actually. Sent from my SM-G935V using Tapatalk
  6. I'll let jjptkd explain. I think it was under powered equipment and room dynamics Sent from my SM-G935V using Tapatalk
  7. Thank you to jjptkd for coming up today. Ahhhh... Bass! So nice! Greatly appreciated! Sent from my SM-G935V using Tapatalk
  8. Ran the jumpers, ran single wires from the XPA5 to the speakers... Unchanged. The speakers will put out bass, but you have to have the volume level up nearly all of the way. Which, the volume that high isn't relaxing at all. Not that I mind loud music, it just doesn't sound good. The woofers still aren't even moving an 1/8" and its not earth shaking. You can set your hand on the woofers and feel them vibrating however. I also swapped the +and - to see if that made a difference. Oddly enough, it made zero difference... Sent from my SM-G935V using Tapatalk
  9. I have done this with and without the jumpers. After hearing originally that the jumper wasn't needed, I set it up again couple weeks ago without it. Sound is just the same with or without it. I'm willing to redo it again with a jumper. Sent from my SM-G935V using Tapatalk
  10. When they were first auditioned, they did move a lot and they pushed a ton of air through the ports. I've yet to duplicate that. Sent from my SM-G935V using Tapatalk
  11. Absolutely not. Barely even 1/8". Sent from my SM-G935V using Tapatalk
  12. It really does seem like the LF is being bypassed. Sent from my SM-G935V using Tapatalk
  13. I'm not running them bi amped. Sent from my SM-G935V using Tapatalk
  14. https://community.klipsch.com/uploads/monthly_05_2015/post-59853-0-19220000-1431021259.jpg https://community.klipsch.com/uploads/monthly_05_2015/post-12390-0-89740000-1431036779.jpg
×
×
  • Create New...