Jump to content
The Klipsch Audio Community

zeeshanmn

New Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About zeeshanmn

  • Rank
    Newbie
  1. Hey guys so recently I got my friend to bring the Klipsch Promedia 2.1 speakers from Canada to here in Pakistan. I was so excited to get them running as soon as they got here. When I brought them home I connected them the usual way. And when I turned on the switch......boom. The electricity flickered and the speakers didn't turn on. I turned around the subwoofer unit observing the rear side of it and then did I realize that it was rated 120V! Whereas here we use 220V. How stupid could I get?! Okay so this is the first time I have got something from US/Canada so I had no idea about the different voltage system. I learned the hard way. Since there is no official presence of Klipsch in Pakistan, and I didn't opt for warranty which would've costed me extra CAD 35 from Amazon.ca, I took the speakers to the repair guy in my area who has fixed my old Logitech speakers and Phillips TV before as well. He tried to fix the speakers but unfortunately couldn't. This is the amp unit: He said the fuse was intact but these 2 components were fried so he replaced them: He did some more soldering and checking with multimeter and all in front of me but the speakers weren't powering on. On some points he was getting readings on his multimeter but not on others (as far as I remember). The repair guy said that this component is damaged (IC?) (highlighted): The repair guy was like I will have to get the replacement part (the whole board as shown in the first picture) from abroad because its not available here in the market. I searched Ebay and did find a few options, but they are either the subwoofer itself or the whole back plate unit. Plus they are really expensive (around $70-$80). Might as well get new speakers from best buy ($125). But even then I don't have anyone coming in from the US. So I wanted to ask if there is any other way I could get these fixed. Maybe the repair guy missed something, or was wrong about something. Need suggestions. Should I try replacing the fuse? I've heard so many good things about these speakers and couldn't even get the chance to hear a single sound from them And they cost me CAD 260! They're just lying here useless in my room.
×
×
  • Create New...