Jump to content
The Klipsch Audio Community

FloridaMichael

New Members
  • Content Count

    2
  • Joined

  • Last visited

Everything posted by FloridaMichael

  1. So... after goofing around a while after writing I have to admit i am a moron. I misread the On/Auto/Off standby and when my receiver said make sure Stand By is off on your woofer, I thought turning Standby Mode meant putting the switch to Off because of my lack of reading comprehension skills lol. The moment I out it in Auto or On Yeah it worked and we enjoyed Frozen 2 and my walls rattled. Well at least I hope people get a good laugh LoL.
  2. I just received my 2 matching r-120sw powered subwoofers. I have 2 receivers 1) Sony Str-dh750 7.2 and Pioneer vsx-50. Both support 7.2 with lfe outs for the subwoofers. I am getting no sound at all from the subs no matter what. first I have 4 Definitive Technology 9080 brand new towers and 1 DT 9080 center. On each receiver i have it set to 5.x with all speakers set to small to make sure that they dont conflict with the sub outs, per the manuals. I have tried 1. just 1 sub on either receiver 2. a mix of large and small just for kicks 3. resetting everything 4. talking to sony who i shared photos with and talked and they said it looked good and should be working 5. changed cables 6. tried 2.1, 3.1, 5,1 etc no luck 7. plugged in my phone for usb input and output and nadda I am really lost. The subs have no lights so i can only assume they are on. Ive tried changing the phase, frequency from 0-lfe and nadda I tried plugging in the cable and tapping the center of the other side like checking a mic, nothing. Please help my new Pioneer lz sc904 is coming soon and I want these working.
×
×
  • Create New...