Jump to content
The Klipsch Audio Community

Tlich

Members
  • Content Count

    6
  • Joined

  • Last visited

Everything posted by Tlich

  1. Thanks Randy. The Nad amp is at my fathers, it has actually been working fine. He went through and heated up all solder joints on the Adcom preamp but never tested it before to see if it was working. He has them both working now. I had assumed I just lost the left channel on the Adcom when the Nad amp direct wired worked fine. Does JEM repair or sell kits with original parts or same specs? I'm not looking for any "upgrades" like crites.
  2. I'm new to hifi and need some help getting to the bottom of my problems. Initial issue: Left channel often seems quieter than right. Initial gear Chorus 1's, Adcom gtp550 pre/pro and Nad 2150 amp. Source was laptop from headphone jack. Speaker placement is not perfect they are in a tight space with a room opening to one side etc. First upgrade was to a Node 2i. Sound still seemed to favor the right channel randomly, the difference has always been slight. Vocals seem to lean right instead of center, this is the best way to describe it, when trying to move from the left to right speaker to compare loudness I couldn't ever be certain. Second issue: Lost left channel entirely. Bypassed preamp and went straight from Node to amp. Sound is restored only issue may be the slight balance issue as previously described. Added new amp Marantz 2240. Sound diminished on left channel more noticeable but still hard to determine for sure. Swapped RCA's from output believe I have ruled the Node 2i out as the issue. Swap left and right speaker wires still can't really determine a difference. Today/ third issue: Left channel significantly different than right almost hardly audible. Swap RCA's from source, remains significantly different, so source is not my problem. Put left on remote speaker output, still diminished. Swap entire L&R speaker wires and left speaker has full sound right now has the issue. I also tested left channel with a tower speaker, issue remains... So it seems my issue today is the left channel on the amp, unless someone has advice or something else to try. My concern is I've lost the left channel completely twice on different amps, could the initial problem be the speaker crossover shorting out the channel somehow? Wouldn't the Nad amp lost the left channel before the Adcom preamp?
  3. Definitely a scam. I also tried to buy these, told him I would be in the area in a couple of weeks. He said I was next in line. Ad went down I emailed to see if they were sold, about a week later same ad was up. I also found the ad on hifishark, I believe. Reached out through the other site, no answer.
  4. Would also consider original Chorus, possibly Fortes.
  5. Looking for a pair of Chorus II's or Cornwalls. Willing to travel a few hours from Columbus, OH area.
×
×
  • Create New...