Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'alk universal'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 1 result

  1. So, I am slowly restoring an old set of Khorns. I just took some measurements of the latest configuration and I'm wondering if this is looking like it's supposed to. Set up: UMIK 1 / REW / about 3 feet off the ground / 3.5 feet from front of Khorn / 1/6 smoothing Woofer: Stephens 103LX (16 Ohm, DCR ~ 10 Ohms) // mounted on slide-in motorboard, with 6"x13" slot Mids: University SA-HF + K-5-J Highs: K77 Tweeter (square magnet) Crossover: I built the ALK Universal crossover with Solen caps and Litz inductors on a k-500-5000 crossover board (1954). I'm using the old autotransformer on the board and the squawker is connected to the -3 and 0 tabs on it. Here are the measurements. Is the woofer response supposed to look like that? It looks like it's not being properly attenuated on the upper end.
×
×
  • Create New...