Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags '1963 Khorns'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 1 result

  1. I recently purchased a pair of vintage Khorns, approximately from 1963. One speaker plays fine while the other has little to no high frequencies. I switched the K55 drivers from one speaker to another. Both K55 drivers seem to work fine in the one speaker, while not working in the other. Respective drivers from one speaker have the same impedance as the drivers in the other speaker. I've swapped out amps and cables. I've also reversed pre-amp to amp connections for left to right and changed output connections on preamp. Loosened and retightened internal wire connections on both speakers. When speakers are disconnected from amps, both speakers have the same impedance at the main terminals. Everything looks original, including the old cross-overs and capacitors. I do not know how to check cross-overs or capacitors. One speaker sounds fine while the other has no high frequencies. Pre-amp is Conrad Johnson PV8. Amps are MV60SE factory monoblocks. Hoping someone can offer some advice. It's late here so I will check post tomorrow.
×
×
  • Create New...