Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'klipschorn woofer'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 1 result

  1. SBQ

    SBQ

    I've opened up my Klipschorns to look for a pair of replacement woofers. It appears I have the K-33 but I see that there are current ones saying it should be K-33E. These are 2002 or at least on the AK4 xover has a QC sticker saying OCT 2002. Can someone point to me where I can get genuine Klipsch woofers? I read that Bob Crites has his ones but uncertain on the difference (he offers both cast and pressed steel). Another thing is i'm in New Zealand and online at Speaker Exchange wants $218 to send which is nearly as much as the cost of the drivers. Look at the mess of this xover - all point 2 point and what's the deal with lump bundling Monster Cables? and here's the printing on the magnet - 4 ohms (I thought they were 8 ohms?) Anyways i've discovered a problem. Using my voltmeter I measure at the LF binding posts of 4.5 ohms but when I use the probes to measure directly at the woofer's terminals I get 4.1 ohms. Should I be concerned? and the woofer is only attached with 4 screws - I hope this was not a cost saving measure?
×
×
  • Create New...