Jump to content

Search the Community

Showing results for tags 'model h'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 2 results

  1. Hey there! I came across these the other day on craigslist and had to pick them up. Plus it was a good excuse to get out of the house. I have yet to take the backs off and peek inside, but when I put my ear up to where the tweeter and squawker should be there doesn't seem to be sound. However, they sound quite pleasant and listening to a sweep of the frequencies I can here to my limit of 16.5k htz or so. Anyway, without delay here are some photos.
  2. I am a noob on the forum and would greatly appreciate help from the community. I picked up a pair of beautiful Model H speakers and would like some help. Links to pics are embedded below. Could use some help with the following: Identify Age - back label is too faint for me to make out serial number. Model looks like HWO12 Pic of speakers face and open back - https://app.box.com/s/6kf8jz39rfhq3z0ulimt2tl7r6yx4ujf Pic of Model H pair next to a Kg4-WO - https://app.box.com/s/7cerrpupwj4hzf9v1nv1a2s2xgdh8hux Pic of Label - https://app.box.com/s/4impoxb2o9h3ypx0n3m3m7sv2dr22i6k Identify Crossover network Pic of open back speaker - https://app.box.com/s/q9c957sjog19wnkp1dtk9blqrftxmnak Pic of Crossover network - https://app.box.com/s/q9c957sjog19wnkp1dtk9blqrftxmnak Pic of Crossover label (looks like 4 RB punched in metal) - https://app.box.com/s/h1yefqj5r7hw41tycfip327e9n5ffnou Additional pics and info tweeter K77 #2935 - https://app.box.com/s/9gdk1jb4bpibpkf6f5r6akvxc71tl3qs squawker horn K1000 - visible in tweeter pic above squawker driver K55V - #3932 - https://app.box.com/s/4eto906m17nthw20gz0e6idligsw4raf woofer K22 #1941 - https://app.box.com/s/x128dkhu1auiuu1lugd0mauhz011mkvi woofer surround is orange/reddish When I check the impedance of each speaker at the terminals on back I get readings of 12.4 ohms on one and 8.2 ohms on the other. Is this an indication of a bad crossover network in the one reading 8.2 ohms? I think these are 16 ohm speakers and in an thread on this forum I read that 12.4 ohms is in the expected range for a 16 ohm speaker. I have two pairs of KG4's of different vintage that I tested with a meter and found the following: Pic of Kg4-WO label - https://app.box.com/s/yjb1ehejktf518hpnfh1xi86o75vdzr8 Nominal Impedance on label 4 ohms impedance measured on one is 4.5 ohm on the over is 7.9 ohms Pic of Kg4-Oak Oil label - https://app.box.com/s/3b8oakziy6e36budpnuz888gjlf87iq4 Nominal Impedance on label 6 ohms impedance measured on one is 4.5 ohm on the over is 4.6 ohms What should I take away from the measurements I've taken?
×
×
  • Create New...