Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'no power'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2019
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 4 results

  1. About 6 months ago, one of my XF-48's wouldn't power on. I put the the pair in the cupboard and ran my XB-10's as main channel. This morning I tried again to power up the XF-48's but now they both won't turn on. I have checked the fuses and power leads but all is ok. Has anyone else experienced this? Any ideas on fault cause? Thanks in advance
  2. Hello everyone, I have a R-10B sound bar that does not turn on. I have tried draining the power supply by having the switch on while having the power sour unplugged from the wall. I was wondering if anyone has a service manual for the power supply or anything at all that would help with this issue? Thanks in advance for any help!
  3. Hey, I purchased the r-15PM's with the r-10SW a couple months ago. Everything worked great, until recently when the monitors won't turn on. The sub's getting power and is working, but the monitors will not turn on. I tried different outlets, manual turn off/on, nothing. What would the next troubleshoot be in my case? How to check if a fuse blew out? Should I use a different power cord and try that? Thank you, Deece
  4. Hello, I noticed last night my display was flickering on my sub I turned it off and back on a few times now it won't power at all. Can anyone help me with the steps I need to take to troubleshoot my sub? Thanks Allen
×
×
  • Create New...