Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'r14'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2019
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 1 result

  1. I could really use some help! I previous used Tannoy powered studio monitors in my Harmon Kardon 3490 connected by XLR to Male RCA cables. I plugged them into the AUDIO Pre-Out. Now I'm hoping to replace them with these Klipsch R-14s, but I cannot for the life of me get the passive signal to work. I used 16-gauge wire, stripped, twisted, and connected to the twists in Speaker 1 section, but nothing. I triple checked connections and polarity, tried banana plugs and everything, but no dice. Do they need to be connected to the PRE Out with a 16 gauge open stereo wire to RCA male? Is there such a wire? I'm so confused!
×
×
  • Create New...