Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'r15-pm'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 3 results

  1. Hey, I have R15-PM for two year now. They worked perfect without any problem, until now. Without any further notice, they suddenly stopped working. So far I've tried different connections (including Bluetooth), and nothing work, no sound at all comes from the speakers. Even the "normal" humming sound has disappeared, they're completely quiet. Do you have any idea what could be wrong? How can I fix the problem? Thanks, Dor
  2. I would like to add a R-52C center channel speaker to my R-15PM + R-10SW sub setup. Since I'd be requiring an AVR for the center channel, am I able to connect the powered monitors to an AVR without risking blow-out? Any suggestions for a mid-range AVR that may work best with the Klipsch speakers? Thanks!
  3. I am trying to connect my computer to my R15-PM over the Bluetooth connection and my computer is asking me for the speaker's PIN. Has anyone had this issue? I can connect through other devices like my phone no problem and without a PIN. Thanks for any tips!
×
×
  • Create New...