Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'rsw 12'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 2 results

  1. I'm selling my Klipsch RSW-12 sub-woofer in the SF Bay area. Link to Craigslist: http://sfbay.craigslist.org/eby/ele/5841263425.html Klipsch rsw12, Klipsch rsw 12
  2. First, I am a complete neophyte and probably don't even deserve to be on this website.... but I have an RSW 12 (about ten years old) that played great until I sold my house and moved the amp 86 miles (carefully) in my SUV to new house and now when I turn on the power the back cone (neophyte remember) clicks/pounds away like a heartbeat. and it wont play (when I connect the Line in from my receiver/amp I don't get any play from it, it just keeps on heartbeating). Anyone got any ideas? I am not inclined to ship it off for repair unless I know there is a definite and affordable repair to be done..... Seems like probably a short? I appreciate any input. Thank you
×
×
  • Create New...