Jump to content

Does anyone have experience with the KL-650-THX


Jeppe
 Share

Recommended Posts

32 minutes ago, Frontino said:

Uhm... Ok... I don't know what happened exactly, but today I reconnected the speaker to my AVR, after putting it back in the box for a few days, and now it works perfectly.

 

I think the issue was not related to the tweeter itself, but something else: maybe a loose wire?

it definitely sounds like an external wire connection being loose or not fully engaged

Link to comment
Share on other sites

Sorry, ignore my last post.

 

I forgot to reset channels trims to 0 before testing the KL-650 again.

 

The crackling still occurs but this time I noticed that it did not start to distort right away, but it took something like a second after pushing the AVR close to 2.83 Vrms.

Link to comment
Share on other sites

On 1/11/2022 at 6:55 AM, Frontino said:

I was testing my newly purchased KL-650-THX connected to a Yamaha RX-V381

This may be a problem.  Your Yamaha is entry level or near entry level and just may not have the horsepower to properly drive your THX system.

 

Bill

Link to comment
Share on other sites

I seriously doubt that:

 

1. The R-51M goes up to volume 0 with no distortion.

 

2. The pink noise has peaks of -10 dBFS digital, which on the Yamaha amount to 20 W at 2.83 Vrms. The distortion occurs even if I connect just the tweeter to the Yamaha and nothing else, meaning a pass band of 1400-2000 Hz and impedance of 9-11 ohms. If the Yamaha can't drive even that at 1 W continous, how can it drive the R-51M with almost 2 W continous and peaks of 34 W when I push it at volume 0?

Link to comment
Share on other sites

15 hours ago, Frontino said:

Sorry, ignore my last post.

 

I forgot to reset channels trims to 0 before testing the KL-650 again.

 

The crackling still occurs but this time I noticed that it did not start to distort right away, but it took something like a second after pushing the AVR close to 2.83 Vrms.

questions  

 

1)-  Are these speakers under klipsch Warranty   -

2)-  do you have another amplifier to test the KL-650  -

3)- do you have a 2nd set of speaker wires , you can  try

4)- is the crackling sound the same in both speakers ? 

Link to comment
Share on other sites

15 hours ago, willland said:

This may be a problem.  Your Yamaha is entry level or near entry level and just may not have the horsepower to properly drive your THX system.

 

Bill

I was running the THX Ultra II system off a Denon 3805 Switched to Emotiva XPA-5's. It was a night and day difference , this system loves power.

Link to comment
Share on other sites

4 hours ago, RandyH said:

questions  

 

1)-  Are these speakers under klipsch Warranty   -

2)-  do you have another amplifier to test the KL-650  -

3)- do you have a 2nd set of speaker wires , you can  try

4)- is the crackling sound the same in both speakers ? 

1. It's only one speaker and yes, I bought it last July and already started an RMA.

2. Sadly, no, I only have the V381 and if I looked for one just 3dB more powerful, I'd have to spend several thousands EUR, whilst the R-51Ms can play beyond reference level with the V381 just fine.

3. Yes, I tried different wires and got same problem.

4. No, the crackling comes out only from the KL-650's tweeter. The KL-650's woofers and the full R-51Ms play fine up to volume 0, which gives me the assumption that the problem is not the Yamaha, otherwise everything would crackle.

Link to comment
Share on other sites

1 hour ago, Frontino said:

1. It's only one speaker and yes, I bought it last July and already started an RMA.

2. Sadly, no, I only have the V381 and if I looked for one just 3dB more powerful, I'd have to spend several thousands EUR, whilst the R-51Ms can play beyond reference level with the V381 just fine.

3. Yes, I tried different wires and got same problem.

4. No, the crackling comes out only from the KL-650's tweeter. The KL-650's woofers and the full R-51Ms play fine up to volume 0, which gives me the assumption that the problem is not the Yamaha, otherwise everything would crackle.

the issue sounds like a defect  with the speaker , the amp is working correctly with other speakers , so the amp is not the issue although under-powered

, Hopefully ,klipsch will send out a replacement speaker or a New replacement part asap   -

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...