Jump to content
The Klipsch Audio Community
Sign in to follow this  
Jerrycfl1

New Member w/ KP 600 Rig - repaint touch up ideas ?

Recommended Posts

Hi all, I just signed up to the board here, and I'm excited to become of the community that you guys have built !  I've been working with Klipsch Home audio gear in terms of sales and installation since 1987 , while working at Read Brothers Stereo in Chas SC, and then became involved with Pro Audio and Lighting in the late 90's.  

 

I have just  repurchased a complete KP 600 system I originally owned years ago, and am now in the process of getting it back to 100%. My rig has  2 x 680 SW, 2 x 650 LF, 2 x 650 HF, 2 x Fly Bars, Aerquip Straps , Dolly Caster plates  and 2 x 600 EC crossovers, all powered by a Carver/QSC rack. Overall the system is in very good shape, and I just need to re cone 2 x K41 M and replace 2 x K78 diaphragms and it should be ready to rock.

 

Since I have the KP 650 MF modules open, I'll take some pics and post them for all to see :) I'm hoping that I can share some info on my rig, and would be glad to help answer any questions that I can.

 

I am curious if any one has a specific paint recommendation for touch on the 600's ? They look in very good shape, but I would like to touch them up some. My KPs have some pretty cool quilted speaker covers that fit on the stack when its on the dolly, and I'll send pics of them too.

 

Thanks again  for all the valuable info that is on the site, and I look forward to meeting you guys.

 

Jerry Seay

Zenithlighting

jerry@zenithlighting.com

  • Like 4

Share this post


Link to post
Share on other sites

Hey Jerry....

Welcome to forum....

Sounds like you have a killer system.... I would love to latch on to more of the Klipsch Pro line... The only pro-line I have is two sets of KP-362's and yes I love the way they sound. I power the one set with a Carver TFM-42 yea it get's em bumping for sure.

What kind of Carver's are you using? I have always liked the way the Carver's sound with the Klipsch.

Post some pic's for sure....again welcome...

MKP :-)

Share this post


Link to post
Share on other sites

Hi all, I just signed up to the board here, and I'm excited to become of the community that you guys have built !  I've been working with Klipsch Home audio gear in terms of sales and installation since 1987 , while working at Read Brothers Stereo in Chas SC, and then became involved with Pro Audio and Lighting in the late 90's.  

 

I have just  repurchased a complete KP 600 system I originally owned years ago, and am now in the process of getting it back to 100%. My rig has  2 x 680 SW, 2 x 650 LF, 2 x 650 HF, 2 x Fly Bars, Aerquip Straps , Dolly Caster plates  and 2 x 600 EC crossovers, all powered by a Carver/QSC rack. Overall the system is in very good shape, and I just need to re cone 2 x K41 M and replace 2 x K78 diaphragms and it should be ready to rock.

 

Since I have the KP 650 MF modules open, I'll take some pics and post them for all to see :) I'm hoping that I can share some info on my rig, and would be glad to help answer any questions that I can.

Welcome Jerry!

We hope you stay for a while and post often :)

I already had a 6 Box KP-600 system and a buddy of mine Kevin Harmon, another friend Roy Delgado, and I just scooped up an additional 30 boxes. Kevin got 6 and already had 6 so he now has 4 stacks, Roy got two high frequency boxes and two mid frequency boxes which he plans on pairing with the new KPT-1802 Horn Sub, and I got the remaining 20 boxes.

The original electronic cross overs are few and far between, Kevin has a pair, and I have a pair. :)

Would love to see some pictures of your stuff!

Roger

 

I am curious if any one has a specific paint recommendation for touch on the 600's ? They look in very good shape, but I would like to touch them up some. My KPs have some pretty cool quilted speaker covers that fit on the stack when its on the dolly, and I'll send pics of them too.

 

Thanks again  for all the valuable info that is on the site, and I look forward to meeting you guys.

 

Jerry Seay

Zenithlighting

jerry@zenithlighting.com

  • Like 1

Share this post


Link to post
Share on other sites

Is it me or does it seem like it's been raining KP 600's lately?

 

Personally, I think it's a wonderful thing!

  • Like 1

Share this post


Link to post
Share on other sites

Welcome to the forum. Do you carry High End Lighting Systems?

Share this post


Link to post
Share on other sites

Hi all, been a little while, busy with a lot of Music Festivals that we are doing lighting for. I'm still working on getting my rig back up, and just got in the 10" recone kits that the KP 600s need. I'll try to post more updates :)

 

 

BTW- if anyone comes across a set of KP 680s for sale, I may be in the market to add more to my rig :)

 

 

And for any that may be interested, Zenith Lighting carries a wide range of Professional Lighting equipment, including ETC, VariLite,High End, Clay Paky, Martin, Robe, AVO and many more, so if I can be of any help on a lighting related project, please contact me @ jerry@zenithlighting.com.

 

Thanks,

 

Jerry Seay

Share this post


Link to post
Share on other sites

Hi guys been off the forum for about two years. Good luck with your KP 600 I have a 24 box system I have been using for the better part of 20 years, still is the best sounding reinforcement I have ever heard!!

If you need any help with them I know them very well as all I use is Klipsch.

Good luck Joey B.

  • Like 3

Share this post


Link to post
Share on other sites

Finally getting around to working on the 600 Rig ! I just reconed the 10" Mids, my 1st attempt at doing so. They meter right, and the voice coils dont rub, so Im hoping that they'll sound right once back in the cabinets. I did run into a problem, both of my EC 600 crossovers have some of the Clip Indicator LED's on even when there is no signal present. I picked up a Furman 4 Way crossover to use while I get the EC 600s sorted out, any recommendations on who may be able to service the EC 600s for me ?

I'm hoping to get my 600's up and operational in the next week or so, so I'll try to send over pics and let you guys know what progress has been made :)

 

Thanks for any and all help .

 

Jerry 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...