Jump to content
The Klipsch Audio Community
Sign in to follow this  
zeeshanmn

Short Circuit my Klipsch Promedia 2.1 on 220V

Recommended Posts

Hey guys so recently I got my friend to bring the Klipsch Promedia 2.1 speakers from Canada to here in Pakistan. I was so excited to get them running as soon as they got here. When I brought them home I connected them the usual way. And when I turned on the switch......boom. The electricity flickered and the speakers didn't turn on. I turned around the subwoofer unit observing the rear side of it and then did I realize that it was rated 120V! Whereas here we use 220V.

 

How stupid could I get?! Okay so this is the first time I have got something from US/Canada so I had no idea about the different voltage system. I learned the hard way. :(

 

Since there is no official presence of Klipsch in Pakistan, and I didn't opt for warranty which would've costed me extra CAD 35 from Amazon.ca, I took the speakers to the repair guy in my area who has fixed my old Logitech speakers and Phillips TV before as well. He tried to fix the speakers but unfortunately couldn't. 

 

This is the amp unit:

th_IMG_20160321_183959.jpg

 

He said the fuse was intact but these 2 components were fried so he replaced them:

th_IMG-20160324-WA00012.jpg

 

He did some more soldering and checking with multimeter and all in front of me but the speakers weren't powering on. On some points he was getting readings on his multimeter but not on others (as far as I remember). The repair guy said that this component is damaged (IC?) (highlighted):

th_IMG_20160321_18423311.jpg

 


The repair guy was like I will have to get the replacement part (the whole board as shown in the first picture) from abroad because its not available here in the market. I searched Ebay and did find a few options, but they are either the subwoofer itself or the whole back plate unit. Plus they are really expensive (around $70-$80). Might as well get new speakers from best buy ($125). But even then I don't have anyone coming in from the US. 

 

So I wanted to ask if there is any other way I could get these fixed. Maybe the repair guy missed something, or was wrong about something. Need suggestions. Should I try replacing the fuse? 

 

I've heard so many good things about these speakers and couldn't even get the chance to hear a single sound from them :(  And they cost me CAD 260! They're just lying here useless in my room.

Edited by zeeshanmn

Share this post


Link to post
Share on other sites

Zee,

Sorry to hear about this.

It reminds me of one of our interns. The intern bought a US spec LaserJet, without asking me for advice. Back in Europe the intern plugged it in (via plug adaptor?) and there was white smoke. I didn't hear any more.

On the technical end, I suspect that there was extensive damage to several components. Your tech found the tip of the iceberg -- and as he alludes to, there are more damaged components.

My thought is that you are basically out of luck.

Let me suggest you might be able to find someone coming back from the States or Canada by consulting with a student association. There must be thousands returning to Pakistan for summer break -- though I think spring break is winding up.

WMcD

Share this post


Link to post
Share on other sites

I believe the entire 2.1 system is (or has been) about $150, and someone here could probably get the sub alone for less than that.  However, the sub is very heavy, so shipping would be cumbersome and costly.  Those aren't real high prices in the USA.

 

You could probably buy the sub component by itself here.

 

I know absolutely nothing about this.  I hope that a forum member who does tell us what he needs to replace and then see if you can find a willing purveyor per Gil's suggestion immediately above.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...