Jump to content
The Klipsch Audio Community
Sign in to follow this  
Descendant

Squawking KLF-30 Legend Speaker - Need Advice

Recommended Posts

I have inherited a pair of Legend KLF-30s but one of them is barely putting out any sound and it seems to be just from the tweeter.  I confirmed it has a good sound signal from the receiver by switching speaker wires around plus I looked inside the enclosure by removing the crossover assembly and do not see any loose wires.  They have been in climate controlled storage for 3 years and have been moved only once or twice after initial installation so I don't think it got dropped so as to dislodge a connection but something is broken.

 

I see Crites offers a cross-over repair kit for $80 as well as replacement crossovers for $280 a pair.  Is that a good way to go?  I am not going to keep them as they are just too big for our place so if I can just solder on a new capacitor from a Crites repair kit that would be fine with me but that seems too simple to be true.  I am no technician so I guess I need a repair guy in Houston - anyone no of a good shop?

 

Any advice will be greatly appreciated!

 

 

Share this post


Link to post
Share on other sites

Do you have a DMM ( digital multimeter) where you can check impedance on each suspect driver? Have you swapped a driver or two to the other cabinet to see if they play louder?

Share this post


Link to post
Share on other sites

You shouldn't be thinking of replacing crossovers until you have figured out what is going on.  If you check the DC resistance of the woofers as AVG stated, you can determine of you have dead woofers, but it seems unlikely that both woofers would go at the same time. It seems much more likely that there is a wiring issue at the crossover. Who knows, mice may have chewed the wires off while in storage. After all, there are big old ports a mouse or rat could get into easily.

Share this post


Link to post
Share on other sites

Is output only from the tweeter or is the tweeter not working?  If the tweeter is the only thing working, you need to definitely start pulling the drivers and checking them with a multi-meter.  Very unlikely you would have blown both the woofers.  Might have had a rodent or two living in the ports eating wires. (hopefully not).

Share this post


Link to post
Share on other sites

When I bought my klf 30s, the tweeter from one and a mid-range from the other didn't work. It turnrs out to be the crossovers. I replaced them with Crites crossovers and they sound great.

Share this post


Link to post
Share on other sites
22 hours ago, dtr20 said:

When I bought my klf 30s, the tweeter from one and a mid-range from the other didn't work. It turnrs out to be the crossovers. I replaced them with Crites crossovers and they sound great.

You were lucky :;) Hopefully you did the right diagnosis to come to that conclusion otherwise for many, it would be a waste of money considering how some people abuse these speakers.

Share this post


Link to post
Share on other sites
2 hours ago, pzannucci said:

You were lucky :;) Hopefully you did the right diagnosis to come to that conclusion otherwise for many, it would be a waste of money considering how some people abuse these speakers.

Best money I ever spent besides my belles

Share this post


Link to post
Share on other sites
On 8/5/2016 at 8:32 AM, dtr20 said:

Best money I ever spent besides my belles

Yes Klipsch would be smart to bring back the KLF line (at least klf20 and klf30).  Better SO acceptance and sound like the Heritage line since the mid and tweeter drivers are pretty much the same.  

The unfortunate part is with a nice looking cabinet, Klipsch would likely have to charge $4k vs the old $2k. 

 

Klipsch if you do, just get rid of the plastic ringed woofers and go with something a little nicer structurally.:D, then you could ask 4-5K.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...