Jump to content
The Klipsch Audio Community
Sign in to follow this  
Blaj Alexandru

R110SW problems

Recommended Posts

Hello everyone! I just buy a new home theathre. My system : av receiver onkyo tx-nr626 - front: klipsch RP-260F - center: klipsch rp-250c - rear: klipsch rp-150m - sub: r110sw

my big problem is that the sub is playing very distorssioned, even my old system (pioneer htp-071) have a very clean bass compared with klipsch r110sw. i turn off my sub to get a good sound because the sound from sub is very very distorssioned at any volume! can somebody help try figuring out what is the problem? maybe i did something wrong

Share this post


Link to post
Share on other sites

Do you have the sub hooked up to the sub out? Where's the gain nob set to? Crossover? Could be several different things. Could also be that you got a defective sub, it happens.

Typed on a tiny keyboard, excuse any grammatical errors.

Share this post


Link to post
Share on other sites

Then I'd take the sub back, assuming it's new. Sounds like a bad sub.

Typed on a tiny keyboard, excuse any grammatical errors.

  • Like 1

Share this post


Link to post
Share on other sites

Definitely return the sub, it is faulty. Nothing more to test at this point

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...