Jump to content
The Klipsch Audio Community
ken6432

KG-300 Gaming Headphones Installing as Mono on PC

Recommended Posts

For some reason, my KG-300 headphones are showing up as a mono device on my PC.  I have them connected to USB and Optical.  Any idea what I need to change to get the PC to recognize them as a stereo device?  I attached a screen shot of the Sound Device Manager dialog.  I am running Windows 10.

 

Thanks for any help.

KG-300 Mono Device.JPG

Share this post


Link to post
Share on other sites

I reloaded my sound drivers which restored the optical output option.  Using this allowed the headphones to work correctly.

  • Like 2

Share this post


Link to post
Share on other sites

Spammer popped in here, thank you for the alert, he has been deleted FOREVER.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...