Jump to content
The Klipsch Audio Community
Sign in to follow this  
Suzanne

New Sound Bar Won't play television audio

Recommended Posts

Just bought a Klipsch Sound bar, R-208, and followed the set up instructions.  I used the digital optical cable to connect it to a Vizio television, and cannot get any sound from the TV to the soundbar.  The blue tooth with my ipad and phone plays fine through the soundbar.  I have tried calling customer support with Klipsch all day, and get the same recording that the service department is in meetings and to call back later.  Can anyone tell me a quick fix for this problem?  I have tried using RCA cables and get no sound that way either.  I've turned the sound off the TV, still nothing. The system seems to be a wonderful as far as the quality of music it produces with my devices, but right now I am about to give Klipsch some very low ratings on customer support.

Can anyone help me solve this problem?

Share this post


Link to post
Share on other sites

Have you tried turning the speakers off in the TV? 

  • Like 1

Share this post


Link to post
Share on other sites
Just now, K5SS said:

Have you tried turning the speakers off in the TV? 

 

Yes, read the television manual as its probably a setting on the television itself.

Share this post


Link to post
Share on other sites
4 minutes ago, K5SS said:

Have you tried turning the speakers off in the TV? 

 

2 minutes ago, jason str said:

 

Yes, read the television manual as its probably a setting on the television itself.

You must go to your TV's setup menu and say no to TV speakers and yes to optical out.

 

Bill

Share this post


Link to post
Share on other sites

I was able to find where I should turn off the TV speakers, but cannot find a setting where I can say yes to optical out.  I'll keep looking, hopefully will find that.

Thanks for the tip.

 

Share this post


Link to post
Share on other sites
2 hours ago, Suzanne said:

I was able to find where I should turn off the TV speakers, but cannot find a setting where I can say yes to optical out.  I'll keep looking, hopefully will find that.

Thanks for the tip.

 

Sorry, I am not sure of the exact wording but my Samsung goes like this:

Sound>>>>Select Speaker>>>>Audio Out/Optical

 

Bill

Share this post


Link to post
Share on other sites

I never could find an output setting on the TV, so I called Vizio and they suggested looking on the Klipsch remote for an input setting (which I could not find).  I fiddled with the soundbar and found the input setting button (which I dont think was specified in the Kiplisch manual setup instructions).  End of story - is that we got it to work.  Sounds great.  Wonderful sound bar for the money, but really, they shouldn't allow their customer support staff to be out of the office for an extended period of time.   Thanks to all that replied to help me.

 

  • Like 1

Share this post


Link to post
Share on other sites

I have two Klipsch bars, 10b and 20b. My first 10b bar had to be returned to Klipsch as the wireless sub would not connect. After that it was fine, 20b worked from day one. Never, on either, did I need to turn off the TV speakers. Optical to bar, plug to power and go. There should be no reason to look at the TV menu and the Klipsch instructions, as marginal as they are, do not show this is needed either. Oh, the 20b + sub plays Big. Happy with both.

Share this post


Link to post
Share on other sites

I just bought a RSB-11 soundbar/subwoofer.  I can't get sound out of it at all. 

Got it connected to HDMI-ARC on the TV.

That's plugged into the TV input on the soundbar.

 

CEC on the TV is turned on.

On the soundbar I did the hold-two-buttons for a few seconds to turn CEC on. 

And here's my silly question: is the Digital Optical cable required? Is that my problem? If so, I'll have to had back across town to Best Buy to get one. 

Thanks in advance for your answers!

Share this post


Link to post
Share on other sites
On 11/17/2018 at 8:49 PM, Janeen said:

I just bought a RSB-11 soundbar/subwoofer.  I can't get sound out of it at all. 

Got it connected to HDMI-ARC on the TV.

That's plugged into the TV input on the soundbar.

 

CEC on the TV is turned on.

On the soundbar I did the hold-two-buttons for a few seconds to turn CEC on. 

And here's my silly question: is the Digital Optical cable required? Is that my problem? If so, I'll have to had back across town to Best Buy to get one. 

Thanks in advance for your answers!

HDMI ports on TVs are usually for input. The soundbar probably has hdmi in and out. If you want to do it this way, have your cable box or Blu-ray player going into the soundbar then hdmi to your TV. If you don't want this, but you want your tv audio output to go to the soundbar, hook up a digital optical cable from your tv to the soundbar. 

Share this post


Link to post
Share on other sites

I recently bought the rsb-11 and when I connect my phone or tv to play music or watch tv the subwoofer will make noise but the sound bar won’t like it’s on mute I tried factory resetting them that didn’t work and reconnecting the woofer the the sound bar multiple times so anything that can help I would be gratefully appreciated 

Edited by Joseph salerno
Didn’t sound right

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...