Jump to content

R-15pm humming with any input


Andyofthedead138
 Share

Recommended Posts

I have a pair of R-15 pm speakers that hum wth any line or phono input.  I returned a pair to the manufacturer and the new ones are doing the same thing.  I just moved to a new place and am wondering if it could be the old wiring in the house?  I plugged up smaller, cheaper speakers to my turntable and didn't have the issue.  It's just my Klipsch speakers.  Any suggestions?

Link to comment
Share on other sites

If you unplug them from EVERYTHING, except an outlet of course, do they hum?

 

If the hum disappears when they are completely disconnected, I suspect a ground loop. I would try running a ground wire from one or both speakers to your source equipment. Not permanently, but as a test. Or, you could try running a ground wire from one speaker to the other, as I see there's a ground lug point on the speaker.

Link to comment
Share on other sites

  • 1 month later...

I'm having the same issue with the R-15PM's I just bought today, the hum is crazy loud. It's there, just a little on Bluetooth, but gets drowned out. With phono, it's terrible. I don't have a ground on my table, but it says grounding is optional.

 

I thought maybe that the electric outlets could be the issue, we have an old house, but moved the speakers and tried them in my kitchen plugs, which do have ground and had the same issue, not being plugged into anything but the outlet. 

 

I bought these from HHGregg, new in box, final sale. I know that I have the warranty, but it's hard knowing I cannot return them to the store. I filled out a ticket for help, which states it can take up to 7 days for a reply. 

Link to comment
Share on other sites

  • 1 month later...

I am having the same issue!! I cannot figure out how to get it to stop. The louder i turn up the volume the louder the humming gets. I have grounded the speaker and the record player, which helps a little bit. Any advice would be greatly appreciated.

Link to comment
Share on other sites

i bought my R15pm speakers/turntable from HH Gregg who went out of business. 

 

The people at Klipsch said three things:

1. My speakers that I just purchased were most likely defective 

2. It is probably the amp inside my speakers

3. Since they were from HH Gregg and they went out of business, they would not fix, replace or repair my speakers.

 

They provided me with the name and phone number of a company who might be able to repair.

 

moral of the story, do NOT buy Klipsch.

Link to comment
Share on other sites

  • 11 months later...

I had the same problem with mine. I bought the Teac TN-400S turntable and a pair of the Klipsch R-15PM and had a humming buzzing noise, I attached speakers to an old turntable did not have. I finally moved system to another room and turns out it did not like the outlet or a nearby device.

Link to comment
Share on other sites

On 5/24/2017 at 10:19 PM, Rkdeem said:

i bought my R15pm speakers/turntable from HH Gregg who went out of business. 

 

The people at Klipsch said three things:

1. My speakers that I just purchased were most likely defective 

2. It is probably the amp inside my speakers

3. Since they were from HH Gregg and they went out of business, they would not fix, replace or repair my speakers.

 

They provided me with the name and phone number of a company who might be able to repair.

 

moral of the story, do NOT buy Klipsch.

Not the klipsch may be outlet I had same problem

Link to comment
Share on other sites

  • 8 months later...
  • 3 years later...

Same humming issue with the phono input. Using a Pro-ject elemental with stock Ortofon OM5E. When the stylus touches vinyl...then Humm. Tried different phono preamp into RCA input  and High power it power supply with no luck. Will try extra ground wire to right speaker....next.  Should of returned them right away! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...