Jump to content

Promedia 2.1 THX Static


Reisman
 Share

Recommended Posts

I have the Klipsch Promedia 2.1 THX model computer speakers - 2 desktop speakers and a large subwoofer. The sound quality is decent, but static (NOT HUM), just ambient static in the background. Windows settings do not eliminate this, and the level of static increases or decreases with the hardware or software volume control. Any suggestions and remedies would be most helpful.

Link to comment
Share on other sites

That's OK.  The Promedia's consistently had problems with what's called a DIN plug, the larger black plug that goes into the back of the subwoofer box..  Fiddle with that and see if the static changes.  Also fiddle with the four speaker wires that also go into the back and see if that affects anything.

 

Finally, turn the volume knob and tone controls back and fort h a few times and see if that affects anything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...