Jump to content
The Klipsch Audio Community
ME2

The Three Firmware Update?

Recommended Posts

Cannot get the WiFi light on the top to light up.  App on iPhone or iPad keeps saying a firmware update is needed.  Can't get to it.  Was hoping it would help the

WiFi setup that is harder than it should be.  Guess I'll just send it back.  

ME2

 

KHorns, Oiled Walnut 1978

Heresys I and II

Cornwalls

The Three (soon to ship back)

Share this post


Link to post
Share on other sites

Some of these gadgets have a factory reset function that I'd try before sending anything back.  Sixes do for sure, thought the threes did, cannot confirm right now.  

Share this post


Link to post
Share on other sites

FACTORY RESET:

 

1. DISCONNECT POWER
2. PRESS and HOLD INPUT SELECTOR BUTTON while RE-CONNECTING POWER

Share this post


Link to post
Share on other sites

Factory Reset dont solve the problem. Dont get any LED flashing on the top either. Is it an software or hardware problem ?

Share this post


Link to post
Share on other sites

There's a wifi setup button on the back, press down for 4 seconds until you hear a beep, there's a green light that will flash, you should be able to connect to the MyPlayDevice in your phone WiFi Settings then open the app to connect it to your wifi network. 

Share this post


Link to post
Share on other sites

i still dont have any success. 

Are your leds on the top working properly?

Share this post


Link to post
Share on other sites
16 hours ago, clgarci2 said:

I finally got it to update the firmware, I tried 4 different USB flash drives. The last one that worked was a newer one that I never had anything on before. Hope that helps.

 

http://assets.klipsch.com/files/theThree_FirmwareUpdate_V02.pdf

 Is the Power Switch put up to the top or to the bottom ? Here you can see it should be to the top http://assets.klipsch.com/files/theThree_FirmwareUpdate_V02.pdf in the users manual from the three they say to turn it off put them to the bottom. 

Share this post


Link to post
Share on other sites

The text in the firmware update sheet is a bit vague... the WiFi LED, means the WiFi setup LED on the back of the unit.  The WiFi LED on the top only lights up when PlayFi is the source.  So WiFi Status on the back and WiFi Source (PlayFi) is on the top with all the other source LEDs.

 

http://assets.klipsch.com/product-manuals/The-Three-Manual-v2.pdf

 

Also, you can't select PlayFi as the source using the source dial, it is selected when you choose the speaker from the Klipsch Stream App.  PLayFi's rules, not ours.

 

Share this post


Link to post
Share on other sites
On 12/2/2017 at 12:46 PM, clgarci2 said:

There's a wifi setup button on the back, press down for 4 seconds until you hear a beep, there's a green light that will flash, you should be able to connect to the MyPlayDevice in your phone WiFi Settings then open the app to connect it to your wifi network. 

 

Regarding WiFi setup,  hold the button 4 seconds for WPS setup (first beep and quick double flashes on the setup LED) or 10 seconds for manual setup (second beep, single quick flashes).

Share this post


Link to post
Share on other sites

I am curious as to how long the Firmware Update takes?  I have 2 of "The Three's" and each appeared to read the USB drive for only a few seconds.  The LED flashed for a few seconds.  Both speakers still show "Update Available" in the Klipsch App.  Any thoughts?  Thanks!

Share this post


Link to post
Share on other sites
20 hours ago, HOOFNIT said:

I am curious as to how long the Firmware Update takes?  I have 2 of "The Three's" and each appeared to read the USB drive for only a few seconds.  The LED flashed for a few seconds.  Both speakers still show "Update Available" in the Klipsch App.  Any thoughts?  Thanks!

Same Problem :(

Share this post


Link to post
Share on other sites
On 12/3/2017 at 12:51 AM, clgarci2 said:

I finally got it to update the firmware, I tried 4 different USB flash drives. The last one that worked was a newer one that I never had anything on before. Hope that helps.

 

http://assets.klipsch.com/files/theThree_FirmwareUpdate_V02.pdf

Please tell us what's format of your usb, how many GB, and the power switch on or off. Thank u so much! How long does it take for the update to complete :)

I've tried so many USB and Fomat many ways

Edited by Huy Nguyen
To complete

Share this post


Link to post
Share on other sites

Same situation here : tried many USB keys, the last one made the top wifi led flash (2 times, many flashes), but then nothing happens : the app still says that there are some updates to implement. Also, lots of disconnection issues, mainly due to the fact that I have to say "postpone" in the app when the firmware update pops up. 

This is very annoying, would be great if someone found a solution !

 

Share this post


Link to post
Share on other sites

Sorry for the double post, but the problem just solved itself today. The app told it needed to update, I downloaded the update on the appstore (iOS) and during the first launch of the updated app, I got a prompt telling me the device needed an update. 

I launched it, it worked for one my two Threes (the speaker made a "bip" sound), I got an error message for the other one. I tried again, and it finally worked. 

Since then, no more "update" message in the app, and both speakers seem to work like a charm. 

 

To sum it up, it seems the new version of the app allows to update the devices "over the air" and without USB keys, and most importantly, works fine. Hope it will stay that way !

 

Share this post


Link to post
Share on other sites

I finally got it to update the firmware

1 Klipsch app

2 settings

3 Troubleshooting

4 reboot all

 update firmware

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×