Jump to content

Klipsch Forte II Tweeter Question


mea2112
 Share

Recommended Posts

I replaced both diaphragms (ordered from Bob Crites) on the K-75 tweeters and they tested at 8.3 ohms. Connected green wire to + terminal and black wire to - terminal but I'm not getting sound out of either tweeter. Could the crossovers on both speakers have problems affecting the tweeters? The odds of that would seem to be low. Any ideas?

Link to comment
Share on other sites

Oh-oh!

 

Did the drivers fit back in the cabinet “nice and easy”or did you have to wiggle them against the cut-outs, kinda force them through?

 

The leads on the diaphragms are VERY delicate. 

 

I THINK Bob makes a point of stating that somewhere, but I am always in a big hurry when I get a package in the mail...

 

I just recently recieved three pairs for my Tangent 5000’s, Cornwall 2’s, and Forte ii’s.

 

I matched the impedance of each pair as closely as possible before installation and had the same issue as you in ONE tweeter.

 

One of my Forte ii’s didn’t work.

 

Sure enough, took it out and hooked up the ohm-meter and it was an open circuit.

 

I had broken the lead.

Link to comment
Share on other sites

  • 2 weeks later...

I rechecked the tweeter wiring and it looks good. Pulled the crossovers and they don't look good. It appears the speakers were used for some time after the tweeter diaphragms bit the dust and the tweeter inductors got so hot they melted.

I'll be ordering new ones from Bob Crites. From what I've read they are great and will be a major upgrade. The bad part is they will cost more than what I paid for the speakers. 

20180113_135842.jpg

Link to comment
Share on other sites

Dang man, that sucks. The Crites drop in crossovers cost a bit but worth it to me on these speakers, there is a noticeable improvement in sound quality, clarity improves and the bass tightens up a bit. Casual listening you may not notice as much but when you're paying attention the little details just flush out a little better. If these speakers are ones you plan on keeping I'd say its money well spent. 

Link to comment
Share on other sites

 

 

 

15 hours ago, jjptkd said:

If these speakers are ones you plan on keeping I'd say its money well spent. 

 

Thanks for the comments. I really have no idea what these things are supposed to sound like. I listened to them for a couple of months with dead tweeters and I thought they sounded pretty good. It will definitely be interesting to hear them with working tweeters and new crossovers!

Link to comment
Share on other sites

  • 3 years later...

@geof Mentioned how delicate these diaphragms are.  Found that out for myself today on some K-75Ks from a Forte II.

 

Pictures show some broken leads at the tweeter's terminals (very zoomed-in photo), I guess the break occurred when I pulled the wires off the terminals?*   (Despite being super careful, the Forte's were unmodded and the spade connector was really stuck on there.)

 

Morale of the story,

  • If you're new to this, don't mess original tweeters just for the sake of dynamatting them.
    • IMO, the tweeter horn is pretty small and plastic is fairly thick, not sure dynamatting does anything anyway.
  • If you're in the middle of your first cross-over re-capping, measure all the speakers Ohm values BEFORE reassembling!
    • In my case, I thought for a second I'd botched the re-capping and blew up the tweeter.
  • Probably stay away from old used tweeters with thin wires going to the terminal leads.
    • Looking at a replacement diaphragm (from Simply Speakers), they have a more robust design, using wider traces.  If anyone knows if Crites' titanium replacements also use a wider trace, please let me know.

* - I later tried re-flowing solder, hoping it was just a cold joint issue.  I wonder if that could have caused this snap in wire instead?

 

Snap_002.thumb.jpg.048917f342065fa47a138651c88176cd.jpgSnap_005.thumb.jpg.ad18da76b139a42c36f1ff3edb485b8c.jpg

Link to comment
Share on other sites

Update.  Was able to solder this, bridging the gap of the wire breakage.  Reads proper 8 ohms, bu who knows if it'll last.

 

Quite the mess, as I originally thought I'd tin the whole length of wire, then lay another wire across to bridge the gap and make more robust overall.

That didn't go so well.  The epoxy that covers the wire just made a flux-like gooey mess.  The solder would stick to the wire, but made no connection to close the circuit (maybe this portion of wire is enameled like the voice coil?)

 

I originally thought a hot bead of solder would melt all that junk away, but no luck.  Maybe should have tried an epoxy removal method (Goo Gone), and perhaps aspirin to remove the wire enamel.  It's such a thin, delicate wire, though, success never guaranteed.

 

Anyway, thought it worth bringing up again as I've read quite a few stories on here about receiving "working" used speakers only to find the tweeter is junked.  It occurred to me that perhaps precisely this same breakage is occurring during shipping / transportation, the culprit being the weight of the wire itself going from the crossover to the tweeter.  A big "perhaps", but perhaps securing the wire closer to the tweeter could mitigate.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...