Jump to content

Keeping Klipsch R-28PF turned on all the time?


ILIV
 Share

Recommended Posts

Unplug them when not in use. I never, not ever, leave my KSP's plugged into the wall, even in standby mode. Unplug from the wall or back of speaker. I've owned KSP's for 18 years and that practice has served the amps well.

 

Keith

Link to comment
Share on other sites

Thanks for replies guys.

 

I've been using remote to turn R-28PF on and off since I originally posted here and I noticed a weird problem. I sometimes walk into a room and speakers are turned on even though they should be turned off. I believe this has happened with Bluetooth and Optical source selected. I don't quite see why would this be happening. The speakers are connected to TV with provided TOSLINK cable. The Bluetooth connection is with Macbook Air which is basically always on. This doesn't look normal to me. Starting to suspect the unit might be defective somehow? This is the only problem I have with it but it is really annoying because to reliably turn the speakers off I need to unplug them.

 

Maybe I don't get how it's supposed to work? Because even though I turn them off with a remote I still can connect via Bluetooth by clicking Bluetooth icon in macOS menubar and then selecting Klipsch R-28PF->Connect. This action turns the speakers on, establishes a Bluetooth connection and iTunes can play music through the speakers. Very convenient but it looks like sometimes it reconnects on its own somehow.

 

Then Optical source shouldn't be capable of doing this, should it? Because when I normally turn on the TV R-28PF never turns on automatically.

 

Anybody knows what the problem might be here? Should I take it to the Klipsch support?

Link to comment
Share on other sites

This has just happened again several times in a row. I was laying on a sofa just staring at LED panel of the right R-28PF speaker and at some point it just turned on with Optical source selected, which is what I used before turning the speakers off with a remote. So, okay, I turned them off again with a remote and continued watching the LED panel. After maybe a minute or two it turned on again, Optical source this time again. I turned it off. After another couple of minutes it turned on again. So, I turned it off once again using a remote and then I got up an pulled out the TOSLINK cable from the right R-28PF speaker. Just experimenting to see if TV somehow sends a wake-up signal or something to the speakers.

Link to comment
Share on other sites

The R-28PF have an auto-wake feature that will turn them on when a source is detected. I'm not sure why they would power on if the connected device is also powered down though. The remote by the way only puts them in standby mode. If you actually want to power them off (and disable the auto-wake) you will need to use the switch on the back of the speakers themselves. 

Link to comment
Share on other sites

On 2/24/2018 at 7:11 PM, Jirachi said:

Any other remotes possibly turning them on accidentally? I've had this a long time ago where remote A would work on tv A, but also do a few random functions on tv B

 

No, that's highly unlikely in this case.

 

On 2/24/2018 at 8:37 PM, KitNorrie said:

The R-28PF have an auto-wake feature that will turn them on when a source is detected. I'm not sure why they would power on if the connected device is also powered down though. The remote by the way only puts them in standby mode. If you actually want to power them off (and disable the auto-wake) you will need to use the switch on the back of the speakers themselves. 

 

Oh yes, I figured it out by trial. Turns out PS4 in Rest Mode, when connected via TOSLINK directly, causes R-28PF to wake up as well. Not just my SONY Android Smart TV. PS4 does this way less frequently, though, compared to the TV. I see how the auto-wake (and auto-sleep) feature is useful but it works poorly with modern devices that operate in standby mode and wake up from time to time to connect to the Internet. Does R-28PF have a firmware that can be modified? Hopefully Klipsch resolves this problem somehow in the future. Or am I too hopeful? This is my first close encounter with Klipsch ever.

Link to comment
Share on other sites

However, when TV is connected to R-28PF with AUX cable the speakers seem to never wake up. Which is sort of strange. I mean, the auto-wake and auto-sleep continue to work regardless of whether I use TOSLINK or AUX. When using AUX, I saw speakers turn off (or rather switching to standby mode and turning off LED indication) after approximately 10+ minutes of inactivity. When I resumed playback in YouTube on TV the speakers woke up conveniently. But they don't seem to wake up at all when TV is in standby mode like it happens all the time when connected via TOSLINK cable instead of AUX.

 

It would be ideal if TOSLINK connection worked the same but unfortunately it does not. I don't see how it is different in this respect. Does it actually carry any sort of commands or information that causes R-28PF to wake up? AUX is dead simple. Not sure how TOSLINK is different.

 

Also, I can't say if Phono or USB cause R-28PF behave like TOSLINK or AUX as I have no devices that work in standby mode and can be connected using those types of connections.

Link to comment
Share on other sites

  • 1 year later...

Hi there
 

I bought my R-28PF and was working ok until the bluetooth started to fail. Now nothing is working...not even though AUX cable. Tried to restart the speakers and nothing is happening. I’m very stressed about this...any help?

Also from the beginning the PHONO connection to my turntable did not work, speakers were making a loud repetitive sound.

Speakers turn on/off normally and can change modes, also connects to Bluetooth where I can pause and play but does not play music. No sound at all!

Any help would be of so much help...

thanks

Edited by ErnestE
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...