Jump to content
The Klipsch Audio Community
Sign in to follow this  
Frank Hoss

Klipsch Wireless Hub RP-HUB1 "The Klipsch HD Control Center "

Recommended Posts

I purchased my Klipsch wireless 5.1 system in December, might have been November.  Just after I got it, when I turned it on, the control center or Hub would do its boot up, and then occasionally go to full volume.  The first time it happened, whatever signal it was pushing through the HDMI temporarily knocked something out of my TV and messed up the display.  First and foremost, it was loud, very, very loud.  Then the TV would not display right like it got struck by lightning or something.  After unplugging and replugging in the TV, it worked fine.  This happened again, but nothing happened to the TV.  From that point forward, I always ensure everything is off, TV, Blu-Ray, or other, so we don't get our ears blasted.

Klipsch's first response was to ensure the firmware was updated.  I don't know if it was or wasn't, but following the steps provided, the firmware was updated after that.  This is the video I sent Klipsch:  https://youtu.be/bH2QRIxQot0.   The Hub went full volume a few more times and Klipsch sent me out a new Hub.  I think I used the system a few times without incident before I left the country for a few months.

I got back a few weeks ago and have used the system two or three times.  Today, the volume went to full volume after its start up.  I am the only person in the house who uses it and I would not have left on full volume when I was finished using it two days ago.

If anyone has any ideas, please let me know.

Thank you,
Frank

  • Like 1

Share this post


Link to post
Share on other sites

Dang.  I bought my system around the same time.  I have not had the same issue you describe.  I'm sure one of the "promised" firmware updates from Klipsch could help.  If you look at their firmware page - we are only TWO days out from it being two years since the last firmware release.  I would push to get it replaced by either your reseller or Klipsch.  There is obviously an issue with your RP-HUB1.  

Share this post


Link to post
Share on other sites

Nope you're aren't the only one.  I think I complained about this in another thread.  It's awesome right?  It's 4am on a Saturday morning and I get up for my weekly long run, turn on the control unit and boom, max volume,  Wakes the whole house up.  It does it at other times as well but those are the ones the wife just loves.  I did have it to were my Tv and cable box would come on with the control unit but to prevent this from happening I stopped that and now I power on the control unit and after I see it isn't at max volume I then turn on my source.  Two years since the last update but I doubt this would fix it.  This system is a lemon.  Not our units but all of the units.  Klipsch promised lifetime updates, "future proof" and even hardware changes if needed.  The haven't delivered on any of their promises and won't respond with a solution.  I think they are waiting for the HD Wireless to quietly go away.  

  • Like 2

Share this post


Link to post
Share on other sites

this is the flaw with these proprietary systems, and my fear with ever purchasing them is it requires sole support from the manufacturer. with a build your own system you can replace individual components to get what you need. I wish klipsch provide better support for there wireless system

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, McBlueMeter said:

Has the wireless system been disconinued???

 

 

Klipsch did update the firmware recently.  I’d like to think they will do a relaunch of the HD Wireless system by 2020.  Hopefully with full bandwidth UltraHD inputs and possibly an option for 5.1.2 Dolby Atmos surround sound.

Share this post


Link to post
Share on other sites
On 10/28/2018 at 5:43 PM, McBlueMeter said:

Has the wireless system been disconinued???

 

 

Looks that way. No longer any trace of it on the website.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...