Jump to content
The Klipsch Audio Community
Sign in to follow this  
Spockster

R112SW needs more gain than R12SW

Recommended Posts

I upgraded my R12SW to a R112SW, and i'm slightly surprised with the outcome. The sub is fantastic. Powerfull, low, clean sound...but one thing bothers me. I use the exact same setup that i used with my R12SW (same level on the yamaha receiver, same position, same test movie). To get the same loudness i had with the R12SW i have to push the gain level to at least the same position as i did with the R12. Does anyone know why? It has way more power than the R12 (300 Watts, the old one has 200). So i can't figure out the reason for that.

 

Thanks in advance for every answer!

Share this post


Link to post
Share on other sites

@Spockster,

 

Welcome to the forum.

 

Input and output sensitivity has more to do with it than output power of the subwoofer amp.  Linearity of the amp/gain also may have something to do with that.

 

Bill

 

Share this post


Link to post
Share on other sites

Thank you very much for your answer. After one week i absolutely love this sub and i wouldn't changw it for anything. 

There's only one little thing i recognised. Everytime the sub switches itself off, i hear a silent "plopp" sound. Very quiet, but recognisable. Is that normal with that sub or is there a problem with the one i got?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...