Jump to content
The Klipsch Audio Community
Sign in to follow this  
Idkdude

Idkdude

Recommended Posts

Hey everyone, Im new and new to the adventure. Tech questions, Purchased a Denon AVR S930H receiver .trying to add two R-15m to the crew , have them hooked up to the surround back.For the life of me ,i can't get them to work. Please help.

Share this post


Link to post
Share on other sites

You will have to connect them to the surround side terminals. Surround back will only work if you already are using surround sides

Share this post


Link to post
Share on other sites
19 hours ago, nitrofan said:

You will have to connect them to the surround side terminals. Surround back will only work if you already are using surround sides

The surround rears are simply the rears and as far as I know always monaural, even in theaters (unless Atmos is not?). Surround sides are stereo in all of them. You should be using sides connection in a 5.x system anyway even though they are behind the LP.

Share this post


Link to post
Share on other sites
23 hours ago, Idkdude said:

Hey everyone, Im new and new to the adventure. Tech questions, Purchased a Denon AVR S930H receiver .trying to add two R-15m to the crew , have them hooked up to the surround back.For the life of me ,i can't get them to work. Please help.

IDK... Dude.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...