Jump to content
The Klipsch Audio Community
DWALT

Suggestions for Replacement Subwoofers for La Scala

Recommended Posts

take a digital volt meter and set it to DC then disconnect your amp from the speakers and turn it on place the meter across the output of each channel and look to see if there is any DC on the output.

Share this post


Link to post
Share on other sites
23 hours ago, Schu said:

I've never heard of a woofer going up in smoke...


I first had an Alpine Slim line 12" woofer in that box my auto install guy built for me and when I was listening very loudly and did NOT have the amps gains set correctly I burned the Alpine Slim Line 12"! It smelled very burned.

John Kuthe...

Share this post


Link to post
Share on other sites

Back to my point 

 

"Unless it's a car audio application and the primary intent is literally rocking the block, I don't think I have ever heard of someone blowing a home audio woofer from excessive volume."

 

I don't play with vintage amps so DC being a culprit wouldn't have come to mind.   

Share this post


Link to post
Share on other sites

Wow, lots to respond to here. I appreciate the input. 

 

The tweeters appear to be unharmed. The smoke was definitely only coming from the Woofer area (I took a brief video before pulling it outside). The house smelled like a bonfire for several days. 

 

I know I'm likely using the wrong setup. So please don't roast me too badly LOL. I have a Carver CT-Seven Preamp and a Carver A-500x Power Amplifer powering them. I know it's probably too much power for them. Both components seem to be operating properly, so I believe I simply had it up too loudly. I'm still currently using the same setup with just one speaker hooked up. 

 

I'll try this weekend to do what Moray James and Ricktate have suggested. If there are issues with the Amp, I'd hate to cause more damaged the La Scalas. 

 

Regarding age, I believe they were purchased in the late 1970's by a family member. Serial numbers are 21T153 and 21T089 (blown up one). 

 

I'm really considering just going with the same K33's. I didn't realize that was what they had come with originally. I still have not opened them up, but again hopefully I can get to it this weekend. 

 

I'd upload that video I was referring to, but I don't see that as an option. 

 

Thank you guys for all of the input. 

 

 

Share this post


Link to post
Share on other sites

sounds like your amp took a dump into your speakers. Any SS amp can have will have some amount of DC on the out put 10 - 100 mA but if you are reading rail voltage at the out put your amp is kacked.

  • Like 1

Share this post


Link to post
Share on other sites

Ya know we love pictures.

 

Maybe there was a squirrel inside there that touched both leads as his body was being bounced around with all the bass....  and...  well....we won't go there.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

My La Scalas prefer a lower wattage setup. I dumped the high power SS stuff in favor of a SEP tube amp with a not so punishing 13 watts/channel.

 

I'd call Bob and swap out the cooked woofer and like everyone recommends, check your amp!

  • Like 2

Share this post


Link to post
Share on other sites
On 10/12/2018 at 6:45 AM, codewritinfool said:

 


Sounds like a great band name.

 

but how do you know when it's done?

 

That reminds me:

Gracie Allen (wife/partner of George Burns) has a recipe for perfect Roast Beef. Take two roasts one small and one large, place in 350 degree oven, when the small roast is burned the large roast is done.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

If you called it a subwoofer maybe its because you want lots of bass just like in your car? You can't just turn up the bass knob and volume.  

Is this what you tried? LaScalas where not designed to go very low,  low end is 3dB or more down at 50 Hz.  and cuts off sharp because the horn just wont handle low end. 

The K33 is not in any way a "high excursion" woofer. Its XMax is maybe 1/4 of an inch, not the inch of travel you may be used to with car or big home subs.  

 

If you indeed pushed 100watts or so thru I hope you where wearing ear plugs because that would have been 120dBm SPL or so. Where you playing that loud? 

Share this post


Link to post
Share on other sites
On 10/12/2018 at 7:02 AM, KlipschFan61 said:

My La Scalas prefer a lower wattage setup. I dumped the high power SS stuff in favor of a SEP tube amp with a not so punishing 13 watts/channel.

 

I'd call Bob and swap out the cooked woofer and like everyone recommends, check your amp!

I push my La Scalas with a Mcintosh MC2105 solid state amp, and it's rated at 105WPC  and has got power output meters and I have to set them to -20dB to show a good dynamic range of power outputs to my La Scalas.

Otherwise the needle just lays there and twitches slightly!

John Kuthe...

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...