Jump to content
The Klipsch Audio Community
Khornukopia

Class D amplifiers are cool

Recommended Posts

7 hours ago, Khornukopia said:

 

The difference I see is the two circuit boards about 3/4" square, correct?, and the TI is the upper picture and the B-B is the lower picture? 

The OPA627AU op amps are shown in the top photo. The OPA1622 op amps are shown in the bottom photo. 
 

I have not tried the LME49720 op amps yet. 

  • Thanks 1

Share this post


Link to post
Share on other sites

OK I am revisiting this, time to get my TPA3255evm up and running and put into a case. I remember vaguely in wdecho's thread which has been removed a discussion about the input grounding scheme on these eval boards. I think @John Warren found an app. note or design note change that describe how to fix the eval. board. @DizRotus do recall any of this?

Share this post


Link to post
Share on other sites

@babadono

 

I recall some discussion, but it was nothing I had to deal with.  Perhaps the fact that I use it in balanced mode makes a difference.  I have the 3255 grounded to the Mean Well power supply and the case.

 

Rich @rhing has more experience with this than I do.  You might contact him.

 

Good luck and keep us apprised.

Share this post


Link to post
Share on other sites
57 minutes ago, babadono said:

OK I am revisiting this, time to get my TPA3255evm up and running and put into a case. I remember vaguely in wdecho's thread which has been removed a discussion about the input grounding scheme on these eval boards. I think @John Warren found an app. note or design note change that describe how to fix the eval. board. @DizRotus do recall any of this?

 I think this is the document describing the issue.  I don't remember anyone figuring out how to fix it.   If you run differential inputs to the amp and bypass the input op amps, I believe you circumvent the issue.

 

http://www.ti.com/lit/an/slaa719/slaa719.pdf

 

Mike

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, mboxler said:

 I think this is the document describing the issue.  I don't remember anyone figuring out how to fix it.   If you run differential inputs to the amp and bypass the input op amps, I believe you circumvent the issue.

 

http://www.ti.com/lit/an/slaa719/slaa719.pdf

 

Mike

Yes I saw this, thank you. But I think John found something even more revealing. IIRC Texas Inst. rev'd their 3250 or 3251 eval boards to correct but they had not gotten around to the 3255 eval board. I remember posting that maybe that is why we're getting them for $75.

Share this post


Link to post
Share on other sites
On 8/23/2019 at 10:36 AM, avguytx said:

So just how good is this little Class D amp for $28 from ebay?  Anyone mess with these?  Kind of intrigued for the money just to tinker with it.

 

https://www.ebay.com/itm/Mini-Class-D-Power-Amplifier-HiFi-Stereo-2-0-Channel-Digital-Audio-Amp-50W-50W/262315996089

 

no preamp needed ----------no tone controls

Share this post


Link to post
Share on other sites
38 minutes ago, babadono said:

Yes I saw this, thank you. But I think John found something even more revealing. IIRC Texas Inst. rev'd their 3250 or 3251 eval boards to correct but they had not gotten around to the 3255 eval board. I remember posting that maybe that is why we're getting them for $75.

 

I ran my 3255 eval board with the SE inputs, and I never could hear harmonic distortion or noise.

The distortion number is still rather low with the side 1 THD+N measurement of 0.013%. There is a bit of difference from the side 2 measurement of 0.0049% due to improper ground plane layout I suppose, but you think you could hear the THD+N number that low with 100Hz at 20 watts?

 

The op-amps convert from SE to differential, because the 3255 chip only has differential inputs if I recall correctly.

I'd try the SE inputs, and see if works out for you. If it's more convenient to input the eval board with differential inputs, then I would go that route.

 

Share this post


Link to post
Share on other sites
1 minute ago, babadono said:

Hey what happened double oh zero?:)

The triple naught spy?

Share this post


Link to post
Share on other sites

Although I exclusively use differential inputs now, before I put my TI TPA3255EVM in a case, I played it in SE.  The switch from differential to SE was accomplished by repositioning jumpers as described in the manual.  In neither configuration do I experience noise, distortion, hum, or grounding issues.

Share this post


Link to post
Share on other sites
11 hours ago, DizRotus said:

Although I exclusively use differential inputs now, before I put my TI TPA3255EVM in a case, I played it in SE.  The switch from differential to SE was accomplished by repositioning jumpers as described in the manual.  In neither configuration do I experience noise, distortion, hum, or grounding issues.

Thanks. I'm striking out trying to "refind" this info. Think I will just proceed.

Share this post


Link to post
Share on other sites
9 hours ago, Khornukopia said:

@314carpenterposted this link on another thread, for the story about the fire at the AKM audio chip factory. I want to help spread the word about this tragedy, so that more forum members are aware of why some audio equipment prices are rising so high.

 

Fire Destroys AKM Audio Chip Factory: Can 2020 Get Any Worse? | Audioholics

 

It gets worse. Much worse. This one costs $400,000,000 in world trade value every hour. Guess who's going to pay.

https://www.cnn.com/2021/03/26/business/global-shipping-supply-chains/index.html

 

  • Like 1

Share this post


Link to post
Share on other sites
On 3/26/2021 at 11:08 PM, 314carpenter said:

It gets worse. Much worse.

 

Maybe you already know the good news, but I just read a post by @Shiva that the ship is freed and trade traffic is resuming.

Share this post


Link to post
Share on other sites

Hi men,

I am interested in a Class D amplifier from Lab Gruppen PDX3000. Could someone tell me which module it is: NCore, Pascal-audio, native Lab Gruppen, other ...
It has a DSP so I want to put it in the bass on my Cornwall III's K33E in active filtering and put my Cary SLI50 on the mid-high horns.
In your opinion is this Class D amplifier of good quality for Klipsch Cornwall IIIs.

 

Specs >>>  https://www.labgruppen.com/product.html?modelCode=P0CBT

 

23x2.jpg

Erb6T1oXYAA-eIt.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Looking for a five channel class D amp section for my HT if anyone has a recommendation. Ive been looking at a used NAD m27 or M28, but if there is money to be saved, I am all ears.

  • Like 1

Share this post


Link to post
Share on other sites

Hi @Schu

 

I don't know if this will help you but be aware that there are pro multi-channel amps, very good for sound and cheap for the stock market. Often they are 4 channels, you just need to take a small pro amp for the fifth channel, there are cheap ones between $ 100 and $ 400

 

For example

https://www.thomann.de/fr/yamaha_xm_4080.htm

 

even with DSP

https://www.thomann.de/fr/qsc_pld_4.2.htm

 

Example for channel 5

https://www.thomann.de/fr/tamp_s75.htm

Share this post


Link to post
Share on other sites
1 hour ago, Schu said:

Looking for a five channel class D amp section for my HT if anyone has a recommendation. Ive been looking at a used NAD m27 or M28, but if there is money to be saved, I am all ears.

There is a company out of England that has caught my eye from time to time.  Nordacoustics, for a direction to explore.

 

https://www.nordacoustics.co.uk

Share this post


Link to post
Share on other sites
5 hours ago, mustang_flht said:

Hi men,

I am interested in a Class D amplifier from Lab Gruppen PDX3000. Could someone tell me which module it is: NCore, Pascal-audio, native Lab Gruppen, other ...
It has a DSP so I want to put it in the bass on my Cornwall III's K33E in active filtering and put my Cary SLI50 on the mid-high horns.
In your opinion is this Class D amplifier of good quality for Klipsch Cornwall IIIs.

 

Specs >>>  https://www.labgruppen.com/product.html?modelCode=P0CBT

 

23x2.jpg

Erb6T1oXYAA-eIt.jpg

Not 100% sure but looks like native LabGruppen

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...