Jump to content
The Klipsch Audio Community
Sign in to follow this  
Nam Nguyen

Problems with Klipsch The Sixes

Recommended Posts

Hello everyone. I purchased a pair of Klipsch The Sixes 3 months ago and having a weird problem with the speakers.

 

When I turned on the speakers, the source signal flashed randomly and then start blinking at Bluetooth signal (blink frequently at 1 second per blink). Couldn't change the source to USB or anything else (i only listen through usb port), tried using both the button on the speakers and the remote to change the source but nothing worked so far.

 

Tried using my iPhone/laptop to connect to the speaker through bluetooth, but both cannot connect to the speakers (error: device not in range...).

 

Tried powering off and on again, tried hold-pushing the source button for >10 seconds to do a factory reset, nothing worked so far.

 

If anyone faced this problem and have a solution, please kindly let me know.

 

Share this post


Link to post
Share on other sites

Got a similar issue: not responding to remote, and bluetooth keeps flashing and unable to pair bluetooth to android or iphone. (phone says it connects, but light on sixes keeps flashing and wont play from bluetooth. Also: not responding to remote, only buttons on the sixes work. Reset not doing anything.

 

This helped some:

I pulled out the power chord, then flipped the switches and did a reset (without the powercable in to "epmty" it of power).

After that did a new reset with the powercable in, and presto, buetooth pairs again!

 

Remote still not working (and yes: I've got new batteries from the store, twice!)

Share this post


Link to post
Share on other sites

Yes, i just got my brand new Sixes today. Tested, the remote does not work. The red light flashes on the remote, but the speaker does not respond to it. But my worse problem is with bluetooth, it keeps disconnecting randomly, i haven't been able to play continuously for longer than 10 mins. I tried on an LG V40, Samsung Tab S6, iPhone 10xs, Ipad Pro, all the same problem. At one stage after switching the speakers off and on again, nothing was able to connect back and it kept saying connection rejected. Is that a known problem?? How to fix it?? I just opened the box 1 hour ago.

Share this post


Link to post
Share on other sites

Same problem as InherentvyasTook the Sixes out of the box yesterday, tried pairing, nothing happening. I have a BCM920702 BT transmitter on my PC, and it worked when I tested it a few months back with a portable BT speaker. Do I need a "gate" or some higher end BT signal provider?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...