Jump to content
The Klipsch Audio Community
Abel

Bar 48 Bluetooth Issue....maybe....

Recommended Posts

I’m using the Bluetooth to play music and the subwoofer isn’t on. Is this normal or a setting I can change?

 

When I swap back to the digital input, subwoofer works fine.

 

Thanks for all and any help. 

Share this post


Link to post
Share on other sites

Have you installed the most recent BAR 48 firmware file (Released on Dec 13th, 2019) from Klipsch's "BAR 48 Support" page ? It is supposed to fix many of the bugs. You can find the correct firmware file by inputting your serial number (Please go to the Klipsch Support Page for more info).

 

If it does not work, then I would suggest you contact Klipsch Supoort for assistance as their are a lot of systems with problems.

 

Update: They revised some of the firmware file online. One of the defective Dec 13th versions was replaced with a Nov 29th version. If you are still having issues, re-check S/N in case they changed your file.

Edited by FMnoise
new info added
  • Like 1

Share this post


Link to post
Share on other sites

Just applied the firmware update as of today, it did fix the subwoofer issue (which my wife hated, and want to make me get rid of it lol)....have not tried the bluetooth yet. Will check in a bit and report back.

  • Like 1

Share this post


Link to post
Share on other sites

Firmware fixed the issue it seems, anyone know what External Player and Installer mode does or how to activate it?

Share this post


Link to post
Share on other sites

I already install mentioned FW for my Bar-48 (As my barcode). The bluetooth can be successfully connect to all my smart phone only. but CANNOT connect to my notebooks. I have 2 smart phone, they are Samsung S8 Plus and S9 Plus. I have 3 new computer notebooks, Acer i5gen10 and Asus quite new. They cannot connect bluetooth to my Bar-48. I dont know why??? Please help.  Whereas They can connect to all my other bluetooth speaker devices such and Klipsch RSB-14, Harman Kadon Go play mini, esquire, jbl flip4, Harman Kardon studio3, etc everything NO PROBLEM at all. I asked Klisch support team they just teach me to how to connect bluetooth and to resetting. I would like to tell that I already did everthing carefully by reading manual,  but bluetooth stiil fail to my notebook. I am so sad nobody can help me.

Edited by Kulanan

Share this post


Link to post
Share on other sites

@Kulanan

I don't know why this is happening. Perhaps some additional information will help...

 

 

Firmware:

  • What version did you install?
  • Did it fix any other problems? This would confirm it installed successfully.

 

You say your notebooks "cannot connect bluetooth to my Bar-48". What do you mean?

  • They cannot see the BAR 48?
  • They can see the BAR 48 but cannot pair with it?

Have you installed the latest firmware and drivers on your notebooks?

What is the distance between the notebook(s) and the BAR 48? Have you tried moving the two devices closer together?

Share this post


Link to post
Share on other sites
On 12/22/2019 at 12:27 PM, Abel said:

Firmware fixed the issue it seems, anyone know what External Player and Installer mode does or how to activate it?

@Abel

 

I just noticed that nobody answered your question...

 

I asked Klipsch tech support about this. They said their website would be updated with information about the two new modes but didn't say when and didn't provide me with any additional information.

Share this post


Link to post
Share on other sites

I hate to be the bearer of bad news about the Bar 48. I had three Bar 48 units over a period of six weeks from Nov 2019 to Jan 2020. Only the first one connected via Bluetooth to my Samsung S8 and my two Windows laptops. The two following units failed to pair with Bluetooth to any device I tried. On top of that, I had three pairs of the Surround 3 rear speakers during that time. At best, the S3 speakers produced a whisper. Klipsch support finally admitted the Bar 48 does not properly provide 5.1 surround sound and Bluetooth has problems, for which they have no date for a firmware fix (I updated to v23 of Dec 2019 on all three of the Bar 48s). Being a long-time Klipsch traditional speaker owner, it was difficult for me to realize the Bar 48 product line is poor in quality and lacking in features the competitors have in spades. I returned all the Klipsch gear for a full refund. I'm now a very happy owner of the JBL Bar 5.1 with rich sound, full surround sound, HDMI-ARC and Bluetooth right out-of-the-box and at $499, is in the same price range as the Bar 48 with Surround 3 speakers when they are on sale.

Edited by DaleG
  • Like 1

Share this post


Link to post
Share on other sites

I just purchased a Klipsch Bar 48 and am trying to hook it up to my Vizio M55-E0. I was successfully able to connect it to my iPhone 7+, but not to the TV. I am using DirecTV mini box to connect to the tv, which is working fine. I have tried to connect with both optical and HDMI, but nothing works. I am desperate for help!!!

Share this post


Link to post
Share on other sites

@Brob412

 

I'm sorry to hear you are having issues. 

 

The first thing to do, if you have not already done so, is to install the latest firmware:

Bar 48 Firmware Update 

 

Next, take a look at this VIZIO support article: Connecting a sound bar with ARC

If your TV has an option to select the audio output format, select Dolby Digital rather than PCM.

 

Are you using the rear Surround 3 speakers with yout BAR 48?

 

Share this post


Link to post
Share on other sites

I just tried to connect again with the ARC and no luck. I also have optical hooked up, but still can't connect. No I am just using the Bar 48 Soundbar with the wireless sub

Share this post


Link to post
Share on other sites

@Brob412

 

There are many issues with the original firmware. Before trying to resolve specific issues you need to ensure the latest firmware is installed.

 

Go here: Bar 48 Firmware Update. Follow the instructions and enter your BAR 48 serial number. If you already have the latest version installed you will be told. If you do not and you can't use your MacBook Pro, use someone else's computer and follow these V83a/V23 Update Instructions to download the firmware and install the app.bin file to a USB thumb drive.

 

If you still encounter issues after having installed the latest firmware I will try to help you resolve them.

Share this post


Link to post
Share on other sites

Ok Thanks. I will have to install the firmware update, hopefully this resolves the issue.

Share this post


Link to post
Share on other sites

I am not sure if it is a Bluetooth issue or not, but everytime my BAR 48 is restarted, like when we turn the TV on,  the subwoofer loses connection.  The only way I can get it to connect back is if I unplug the power from the sub and wait for the light to go off and then plug it back in to power the sub back up, and then it connects.  I did the firmware update, but it still happens.  Any ideas on next steps?

 

Thanks, 

Patrick

Share this post


Link to post
Share on other sites

@pd2002

 

Hi Patrick,

 

I can think of two possible reasons why this is happening;

  1. The firmware update didn't complete successfully.
  2. Your hardware is defective. Your BAR 48 may be from very old stock that experienced this issue before Klipsch revised the hardware.

Try to update your firmware again and watch the lights on the bar to see if it installed successfully. If that doesn't resolve your issue you can either

  1. Return the unit.
  2. Open a support request with Klipsch here: https://support.klipschgroupinc.com/hc/en-us

 

Share this post


Link to post
Share on other sites
On 2/22/2020 at 10:09 PM, pd2002 said:

I am not sure if it is a Bluetooth issue or not, but everytime my BAR 48 is restarted, like when we turn the TV on,  the subwoofer loses connection.  The only way I can get it to connect back is if I unplug the power from the sub and wait for the light to go off and then plug it back in to power the sub back up, and then it connects.  I did the firmware update, but it still happens.  Any ideas on next steps?

 

Thanks, 

Patrick

@pd2002

 

I have noticed the same issue with mine. The only way to reconnect is to remove power from the subwoofer as you described.

 

I have added this to the list of issues I have reported to Klipsch tech support. It's been two months now since I began reporting issues and the only response I have received is that they are working on them. 😞

 

Once I learn something, I'll update these threads.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Can I still do the firmware update for the bar 48 if I have already paired the surround 3 speakers? I didn’t know anything about the firmware update. 

Share this post


Link to post
Share on other sites
17 hours ago, Shann-85 said:

Can I still do the firmware update for the bar 48 if I have already paired the surround 3 speakers? I didn’t know anything about the firmware update. 

@Shann-85

 

Of course and the new firmware definitely helps with the sound levels from the Surround 3 speakers when listening to a Dolby Digital source.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...