Jump to content
The Klipsch Audio Community
FloridaMichael

No Sound Brand new R-120SW Subs

Recommended Posts

I just received my 2 matching r-120sw powered subwoofers. I have 2 receivers 1) Sony Str-dh750 7.2 and Pioneer vsx-50. Both support 7.2 with lfe outs for the subwoofers. 

I am getting no sound at all from the subs no matter what. 

first I have 4 Definitive Technology 9080 brand new towers and 1 DT 9080 center. 

On each receiver i have it set to 5.x with all speakers set to small to make sure that they dont conflict with the sub outs, per the manuals. 

I have tried
1. just 1 sub on either receiver
2. a mix of large and small just for kicks
3. resetting everything
4. talking to sony who i shared photos with and talked and they said it looked good and should be working
5. changed cables
6. tried 2.1, 3.1, 5,1 etc no luck
7. plugged in my phone for usb input and output and nadda

I am really lost. The subs have no lights so i can only assume they are on. 

Ive tried changing the phase, frequency from 0-lfe and nadda

I tried plugging in the cable and tapping the center of the other side like checking a mic, nothing. 

Please help my new Pioneer lz sc904 is coming soon and I want these working. 

  • Like 1

Share this post


Link to post
Share on other sites

Where do you have the output level knob set?

  • Like 1

Share this post


Link to post
Share on other sites

So... after goofing around a while after writing I have to admit i am a moron. 

 

I misread the On/Auto/Off standby and when my receiver said make sure Stand By is off on your woofer, I thought turning Standby Mode meant putting the switch to Off because of my lack of reading comprehension skills lol. The moment I out it in Auto or On 

 

Yeah it worked and we enjoyed Frozen 2 and my walls rattled. 

 

Well at least I hope people get a good laugh LoL. 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Alla well that ends well.  Welcome to the forum. 

Share this post


Link to post
Share on other sites
On 4/9/2020 at 1:07 AM, FloridaMichael said:

I just received my 2 matching r-120sw powered subwoofers. I have 2 receivers 1) Sony Str-dh750 7.2 and Pioneer vsx-50. Both support 7.2 with lfe outs for the subwoofers. 

I am getting no sound at all from the subs no matter what. 

first I have 4 Definitive Technology 9080 brand new towers and 1 DT 9080 center. 

On each receiver i have it set to 5.x with all speakers set to small to make sure that they dont conflict with the sub outs, per the manuals. 

I have tried
1. just 1 sub on either receiver
2. a mix of large and small just for kicks
3. resetting everything
4. talking to sony who i shared photos with and talked and they said it looked good and should be working
5. changed cables
6. tried 2.1, 3.1, 5,1 etc no luck
7. plugged in my phone for usb input and output and nadda

I am really lost. The subs have no lights so i can only assume they are on. 

Ive tried changing the phase, frequency from 0-lfe and nadda

I tried plugging in the cable and tapping the center of the other side like checking a mic, nothing. 

Please help my new Pioneer lz sc904 is coming soon and I want these working. 

Just received my Klipsch R-120SW subwoofer and added it to my Dali Kubik One Soundbar. Fantasic pairing and wowwwwww Sound!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...