Jump to content
The Klipsch Audio Community
Darqman

Constant thump from R-115SW

Recommended Posts

My R-115SW has worked perfectly since I bought it 03/25/2016. Last night I paused a movie and a constant thump was coming from the sub. I turned the receiver off and it continued. I unplugged the LFE cable and the thump continued. The only way to get it to stop is to unplug the power. I've left it unplugged for an hour and plugged it back in (without any input) and the thump starts again. So, am I out of luck or is there some fix for this? I submitted a support request but don't have high hopes.

Share this post


Link to post
Share on other sites

Sorry about your misfortunes.  I say challenge Klipsch on the 2 year electronics warranty.  Subwoofer amp failure is a known issue and they should stand by it.  I never say anything like this publicly but until Klipsch starts sourcing more reliable subwoofer amps, I will not buy their subs.  Not really sure what has changed, but my 13 year old Klipsch RW-10d is still in service trouble free.  My 12 year old RSW-10d failed last year.  Love that sub and still need to get it repaired.

 

Bill

Share this post


Link to post
Share on other sites
6 minutes ago, willland said:

I never say anything like this publicly but until Klipsch starts sourcing more reliable subwoofer amps, I will not buy their subs. 

I have no problem saying it.  I won't buy any of their powered products.  Passive for me.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks.  What's the best way to challenge the 2 yr warranty? 

 

Do you know if I can drive this sub in passive mode with an external amp? 

Share this post


Link to post
Share on other sites

Just contact Klipsch. Me and several others have got replacement amps after warranty period, I guess they have to be generous about these trouble amps to keep some sort of good repetition up.

Skickat från min HD1913 via Tapatalk

Share this post


Link to post
Share on other sites

I sent a support ticket in last week and haven't received a reply. I tried calling today and get a message they are performing monthly maintenance and have limited access, call back later. How a company this big can just shut phones down is crazy to me.

Share this post


Link to post
Share on other sites
11 hours ago, Darqman said:

I sent a support ticket in last week and haven't received a reply. I tried calling today and get a message they are performing monthly maintenance and have limited access, call back later. How a company this big can just shut phones down is crazy to me.

 

We're living in crazy times with this pandemic and huge companies all over the world have been brought to their knees and are running on skeleton staff. So a big company like this could easily shut down it's phones at a time like this... be that as it may, in my experience, Klipsch always take at least a week to respond to support queries, so I'd give it another week or so to account for the pandemic...

  • Like 1

Share this post


Link to post
Share on other sites

3rd straight day they are doing system maintenance? Yeah, right...

 

Nobody answers phones, nobody replies to emails and nobody monitors these forums. Not a good look for Klipsch. 

 

I work for a global company with 6000 employees in eight counties and we've continued to operate. Most importantly, we answer our customer calls when they call. 

 

Share this post


Link to post
Share on other sites

Klipsch customer service is absolutely horrible. Hasn't changed much since this pandemic started. Still equally horrible. When I was able to get in touch with someone after waiting on hold for forever about a year ago they didn't even know their own products. I got so frustrated with the guy I hung up after I told him to learn the products he's supposed to support. Typical corporate company.. as these things go,, it won't get any better unfortunately. Good luck man. 

Share this post


Link to post
Share on other sites
On 7/20/2020 at 1:45 PM, Darqman said:

I sent a support ticket in last week and haven't received a reply. I tried calling today and get a message they are performing monthly maintenance and have limited access, call back later. How a company this big can just shut phones down is crazy to me.

THEY'RE SHUT DOWN ,   due to Covid 19-------------I've been trying to reach them for a week now-------------no answer -------

Share this post


Link to post
Share on other sites
On 7/17/2020 at 1:08 AM, Darqman said:

My R-115SW has worked perfectly since I bought it 03/25/2016. Last night I paused a movie and a constant thump was coming from the sub. I turned the receiver off and it continued. I unplugged the LFE cable and the thump continued. The only way to get it to stop is to unplug the power. I've left it unplugged for an hour and plugged it back in (without any input) and the thump starts again. So, am I out of luck or is there some fix for this? I submitted a support request but don't have high hopes.

you could bypass the plate amp , and wire the connectors to an external amp ---------------that would tell you if the woofer is good , and this could get the sub working as a passive unit  until you get the amp fixed

Share this post


Link to post
Share on other sites

The woofer is good. It works when I play a movie. But the thump continues when movie stops and even if I unplug LFE cable. Unplugging power cable is the only way to get it to stop. 

 

I just ordered a new amp from The Speaker Exchange. It's already shipped. If Klipsch every decides to open for business again and send me a replacement I'll have a spare.  

 

I will tell you if I ever replace the speakers in my home theater again they won't be Klipsch's. Just shutting operations down completely and ignoring customers is ridiculous. 

 

Share this post


Link to post
Share on other sites

, I believe the warranty is 2 years on electronics and 5 years on the rest  ,

 

-now what if the problem is software related ----you would have to ask Klipsch tech support for assistance -----

 

 

 

Klipsch Group, Inc, (KGI) warrants to the original retail purchaser that this product is to be free from defective materials and workmanship for a period of two (2) year on electronics and five (5) years on woofer, cabinet and non-electrical mechanics, from the date of purchase, if it is properly used and maintained. If this product proves defective in either material or workmanship, KGI, at its option, will (a) repair the product, or (b) replace the product, at no charge for parts or labor. If the product model is no longer available and cannot be repaired effectively or replaced with an identical model, KGI at its sole option may replace the unit with a current model of equal or greater value. In some cases, modification to the mounting surface may be required where a new model is substituted. KGI assumes no responsibility or liability for such modification. To obtain a repair or replacement under the terms of this warranty, please return to dealer first, if possible, and the dealer will direct you accordingly for repairs or replacement. You will be required to submit a copy of the original receipt. Return shipping for exchanges/repairs is the sole responsibility of the original retail purchaser.

 

 

Share this post


Link to post
Share on other sites

What amazes me is how I get 2 or 3 marketing emails from Klipsch every day. Apparently they have the resources to sell and ship speakers, they just can't (um, won't) support you once you become a customer.

Share this post


Link to post
Share on other sites

You're out of warranty. I would do a search for authorized Klipsch repair services and send it there.

 

There is an eBay seller who markets repair of Klipsch amps. Don't know if they're authorized. Many good reviews. Might be worth a shot.

Share this post


Link to post
Share on other sites
21 hours ago, Darqman said:

What amazes me is how I get 2 or 3 marketing emails from Klipsch every day. Apparently they have the resources to sell and ship speakers, they just can't (um, won't) support you once you become a customer.

it's Covid 19-----and klipsch is no exception -

Share this post


Link to post
Share on other sites

Covid 19 means you can't reply to a simple inquiry in 3 weeks? That's ridiculous. 

Share this post


Link to post
Share on other sites

 that' s the reality   for the past few months and not just weeks  ----voice your concerns to them   when they re-open up , they gotta open up sooner or later -

Share this post


Link to post
Share on other sites

Try the Klipsch Owners Group page on Facebook many of the top level Klipsch guys are on there contributing daily and may be able to assist.  Trey Cannon comes to mind.

Share this post


Link to post
Share on other sites

Got mine from The Speaker Exchange last week and have fitted it in. Works perfectly so far, touch wood.

Sold out and now on backorder until September or October. There seemed to have been a lot sold in the past few weeks. Looks like all the amps were going bad in close proximity to each other. I purchased my Klipsch Subwoofer in 2017. Three years is not long for a product that cost me within a region of £500-£600.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...