Jump to content

Still going strong!!!


Learux
 Share

Recommended Posts

  • 2 weeks later...

Good to hear there are people out there still enjoying their old Pro's just as much as I am. Ever since I got the CP-1 they've been perfect and loud as hell. It's too bad some people have problems and get discouraged about Klipsch products. Any time you build more than one pair of ANYTHING you run the chance of defects.

Keep up the good work Klipsch, you have a customer for life here! 9.gif

Link to comment
Share on other sites

  • 4 weeks later...

----------------

On 11/22/2002 9:07:43 PM Learux wrote:

Just launched myself a new job, a really great one.

Anyway out of joy I started drinking beer and cranking up the old pro medias!!

They still rock and if they blow ill be happy to go pick up the new 5.1's

Cheers Klipsch to a great product!!!

Same here! I have had my ProMedia Klipsch Promedia v.2-400 since 12/1999 (3 years old!). It still rocks. I don't need the fancy stuff (5.1 setup, etc.) since my hearing isn't good. I just want bass. :)

Link to comment
Share on other sites

  • 2 weeks later...

My v.2-400's are sounding well right now(bought in '99). I have some static noise when i listen to MP3's but i'm not sure if its the quality of the rip or the speakers going to hell. CD's sound good most of the time, its just the high notes that do it. The sub still hits great.

Link to comment
Share on other sites

  • 3 weeks later...

those of you who are experiencing some static, hiss, crackling, etc... get the CP-1 (control pod) upgrade. after using mine for about a year, mine started to develop this problem. so i replaced the control pod and ever since thye've been awesome and flawless. the new control pod is really nice because it has a headhphone jack right on them and you can mute the speakers too.

anyway, i love my klipsch!

now seeing so many people have such bad experiences with their PM's, I'm wondering what the ratio between people who haven't had any problems with their PM's to people who have.

someone should start a poll.

Link to comment
Share on other sites

  • 2 weeks later...

I bought my v2 400's when they first came out. Still running them on my pc.

what is it, over 3 years now?

The only problems I never quite figured out were the hissing and crackling sounds.

When I watch movies and turn the volume up half way, it goes sssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss

When i turn up the volume while playing music, they crackle.

Now I think the cables going to the back satellites are bad, cuz the back sats have crackling tweeters.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...