Jump to content

Cinema 600 Sound Bar Thread


Chief
 Share

Recommended Posts

20 hours ago, Droneface said:

Will my 2011 Samsung-55" Class / LED / 1080p / 240Hz / 3D/ HDTV-UN55D8000Y work with the Klipsch Cinema 600 3.1 soundbar?

 

That depends what you mean by work. Check the manual for your TV.

 

There are three ways the soundbar can be connected. In order of preference, they are:

  1. HDMI-ARC
  2. Digital
  3. Analog

Even if your TV supports HDMI-ARC the specifications are somewhat open to interpretation and not all manufacturers have implemented them exactly the same way so there could be some communication issues, especially with older implementations. The only way to know for sure is to try it.

 

I suggest you review these Cinema 600 articles.

 

Link to comment
Share on other sites

On 1/10/2022 at 12:12 PM, KevinB said:

 

That depends what you mean by work. Check the manual for your TV.

 

There are three ways the soundbar can be connected. In order of preference, they are:

  1. HDMI-ARC
  2. Digital
  3. Analog

Even if your TV supports HDMI-ARC the specifications are somewhat open to interpretation and not all manufacturers have implemented them exactly the same way so there could be some communication issues, especially with older implementations. The only way to know for sure is to try it.

 

I suggest you review these Cinema 600 articles.

 

Thanks, Kevin. I appreciate the guidance. 

Link to comment
Share on other sites

16 hours ago, NickYeram said:

Has anyone run into this?

 

Yes, it happened to me and, if I remember correctly, someone else reported the same thing.

In my case, the soundbar was completely dead.

 

If it is new, you should return it to the retailer from whom you purchased it. If you can't do that, you should be able to get a replacement from Klipsch. If it is still covered by the warranty you should have no problem. If the warranty has expired, they may still be able to help you if you ask nicely.

 

There is one other thing you can try first. If the soundbar is not completely dead, you may be able to revive it by disconnecting the power cable then reconnecting it 10-15 seconds later.

 

Please let us know what happens.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...