Jump to content

KLF30 Woofer Issue ? Not sure if fixable?


Recommended Posts

4 hours ago, Biscuit said:

I can now confirm that this was the noise. Fixed now. Thanks all for the advice, and input and pics!

 

that's good for you. Make sure that you glue the screen back over the pole piece vent hole (where it came from) or your speaker will have different characteristics from all the others.

  • Like 1
Link to comment
Share on other sites

22 hours ago, moray james said:

that's good for you. Make sure that you glue the screen back over the pole piece vent hole (where it came from) or your speaker will have different characteristics from all the others.

 

Yep, I did that. 

Link to comment
Share on other sites

On 3/19/2021 at 2:06 PM, Biscuit said:

I can now confirm that this was the noise. Fixed now. Thanks all for the advice, and input and pics!

 

Did you re-use the original dust cap   -

Link to comment
Share on other sites

1 minute ago, Biscuit said:

I did. I used a plastic cheese knife to slowly remove it with no damage to either it or the cone.

good job ,  these are delicate , one can't use heat on these woofers , they curl right up

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...