Jump to content
The Klipsch Audio Community
SWL

Spotify Problems Lately?

Recommended Posts

I've had Spotify since the beginning. Used it on a Windows machine for years and it was practically flawless that whole time.

 

A few months ago I went to using a Bluesound Node 2i with Android to control it. It worked good, not great but I'm not that picky.

 

In the last couple weeks it has really been acting up and is almost to the point of being unusable. I mean.....I just don't have that kind of patience.

 

Other services through the Node 2i seem to work fine. Anybody else been having issues with Spotify lately?

 

Thanks!

 

Sent from my SM-G950U using Tapatalk

 

 

Share this post


Link to post
Share on other sites

Following as I just got a Node 2i.

  • Like 1

Share this post


Link to post
Share on other sites

I noticed this past week that Spotify music played on my Node 2i sounded lower res than before and definitely not nearly as good as Amazon HD. I thought it was just my imagination.

 

but... the node 2i had 2 firmware updates the past couple of weeks and after those I first noticed a change

 

Amazon HD music still sounds fantastic

Share this post


Link to post
Share on other sites
I noticed this past week that Spotify music played on my Node 2i sounded lower res than before and definitely not nearly as good as Amazon HD. I thought it was just my imagination.   but... the node 2i had 2 firmware updates the past couple of weeks and after those I first noticed a change

 

Amazon HD music still sounds fantastic

 

 

LOL. That's interesting because since this started acting up, it was right after I got the "upgrade" and I swear even though it's been flaking out, the sound quality has been awesome. Better than usual.

 

  

I was wondering with the lossless thing being implemented sometime this year that maybe they're experimenting right now? Total speculation on my part.....

 

Sent from my SM-G950U using Tapatalk

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

I stream Spotify from phone to car stereo no problems. Laptop to monoprice hybrid integrated can be choppy, but I chalked that up to the internet in my office. Stream Spotify to Shield and chromecast with no issues. My guess it's the device that sends/receives that is the issue.

Sent from my SM-G986U using Tapatalk

Share this post


Link to post
Share on other sites
I stream Spotify from phone to car stereo no problems. Laptop to monoprice hybrid integrated can be choppy, but I chalked that up to the internet in my office. Stream Spotify to Shield and chromecast with no issues. My guess it's the device that sends/receives that is the issue.

Sent from my SM-G986U using Tapatalk


That's what I was thinking also but when I use Spotify/Android with my Bose qc35 ii headphones it's been acting up as well. Not as bad as with the Node....but uncharacteristically a little flakey.

Sent from my SM-G950U using Tapatalk

Share this post


Link to post
Share on other sites

I don't know.....I've tried restarts, reinstalls etc.

Sent from my SM-G950U using Tapatalk

Share this post


Link to post
Share on other sites

I know I am crazy but after seeing this thread and rebooting Spotify I listened to a number of tracks I know pretty well and now Spotify sounds better than ever.

 

again I know I am cray cray but I spent hours listening to Spotify versus Amazon the other day and Spotify sounded much lower res than before but now it sounds as good as the best of Amazon

Share this post


Link to post
Share on other sites

Got a Spotify update this morning now everything works as it should.

Sent from my SM-G950U using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, SWL said:

Got a Spotify update this morning now everything works as it should.

Sent from my SM-G950U using Tapatalk
 

I downloaded the Spotify update this morning and now Spotify sounds as good to me as Amazon HD and that was not the case before. There is music I can’t find on each streaming service so I like having the options to play from Spotify and Amazon HD music

  • Like 1

Share this post


Link to post
Share on other sites

I may have tor check for this Spotify update as I've noticed over the last week that I was having a helluva time getting my phone to control the desktop app like it's always done so flawlessly.  I've been running both Spotify Duo, as my son needs his own account so it doesn't jack up my playlist, and also Amazon HD since it sounds better.  I still hate Amazon HD's layout and use along with not being able to save artists and then go to them and see their complete discography unless you actually search for the artist.  I've also noticed it sounding more dull and flat but maybe that's just how the Belle clones sound to me since I had been running the ads L1230's the last few months.  lol

 

Sure would be nice if Spotify went lossless.

 

Is this the version you  guys are on?

 

image.png.c69d6ee6bbd533b4bbbc7978dac43a42.png

Share this post


Link to post
Share on other sites
21 minutes ago, avguytx said:

Is this the version you  guys are on?

yes

 

Make sure all of your settings within Spotify are where they should be.

Share this post


Link to post
Share on other sites

I was reading about their new "look" for the desktop app but mine looks no different at all compared the pics they've shown of it.  Looking at reviews, their update doesn't seem to be that popular so far.  All of my settings are good to go.

Share this post


Link to post
Share on other sites



I may have tor check for this Spotify update as I've noticed over the last week that I was having a helluva time getting my phone to control the desktop app like it's always done so flawlessly. 


That's what was happening to me on Android. It would lock up, show incorrect information and other goofy stuff. Totally uncharacteristic of Spotify in my past experience.

Right after the update it worked great but since then it has had a couple hiccups......nothing major.

I don't know what's going on but Spotify through the Node 2i recently sounds so good I really don't care anymore if they go lossless or not.

Maybe it's my new power cables.


Sent from my SM-G950U using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...