Jump to content
The Klipsch Audio Community
Yash

Low dialogue while watching movies on R-41PM

Recommended Posts

I have a R-41 Powered Monitors and a R-120SW connected to my TV via optical. When watching movies the dialogue is very Low compared to my 5 year old soundbar. The two channel setup has a much more immersive experience but how do fix the dialogue issue I am having? Any advice or tips?

 

If these speakers are just built this way do you think higher end models like the R-51PM or the Fives might make a difference?

 

Cheers

Yash

Edited by Yash
  • Like 1

Share this post


Link to post
Share on other sites

There must be audio settings in your TV that's sending the dialog to a dedicated center channel which your TV perceived was the soundbar. You have to tell your TV  (or whatever controls the audio of your A/V system) that you only have two front speakers. You'll probably also have to specify they are SMALL vs. LARGE. So experiment with the TV's audio settings.

 

What's the make and model of the TV?

Share this post


Link to post
Share on other sites
9 hours ago, Peter P. said:

There must be audio settings in your TV that's sending the dialog to a dedicated center channel which your TV perceived was the soundbar. You have to tell your TV  (or whatever controls the audio of your A/V system) that you only have two front speakers. You'll probably also have to specify they are SMALL vs. LARGE. So experiment with the TV's audio settings.

 

What's the make and model of the TV?

Unfortunately once I set the tv sound to optical the tv audio settings are disabled. I will try and experiment with the inbuilt app setting ie Netflix and switch to 2ch or stereo and see if it makes a difference. 

Share this post


Link to post
Share on other sites

My guess is, you have to run the optical audio output from the TV to an A/V receiver and not directly into the speakers. Your speakers are probably not meant to be connected to a TV's optical audio output but rather a solely audio output such as a CD player with an optical jack.

 

The TV's optical audio output probably needs to be connected to an A/V receiver and then to a pair of passive speakers vs. directly into the powered speakers.

Share this post


Link to post
Share on other sites

Thanks Peter. Klipsch does mention on the manual that the optical can work from the tv directly. But maybe different tv models perform differently. Trying it with an amp might just be the next best option and will visit the showroom to test before I invest in one coz I don’t own an amp currently. 
 

If I knew I’d run into these issues I would have just got an amp and passive speakers from the beginning 😫. Newbie experience lol

55B6A700-BB04-468C-A0CB-638B1A768A48.png

Share this post


Link to post
Share on other sites

You may not need an amp, but a preamp/AV processor. You might be able to repurpose an A/V receiver.

 

Those instructions you provided say the TV must be set to PCM (or Stereo only). Have you experimented with those settings?

Share this post


Link to post
Share on other sites
24 minutes ago, Peter P. said:

You may not need an amp, but a preamp/AV processor. You might be able to repurpose an A/V receiver.

 

Those instructions you provided say the TV must be set to PCM (or Stereo only). Have you experimented with those settings?

 

24 minutes ago, Peter P. said:

You may not need an amp, but a preamp/AV processor. You might be able to repurpose an A/V receiver.

 

Those instructions you provided say the TV must be set to PCM (or Stereo only). Have you experimented with those settings?

Yep I have set my tv to PCM. There is no stereo option on my tv.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...