Jump to content

RSW-12 finally gave out, looking for repair help


scubabuzz
 Share

Recommended Posts

My RSW-12 seems to have finally gave out or at least it seems the power supply has.  It did not blow the fuse but when I enable power the front LED flashes red and then goes out.  Sometimes I hear a bit of noise from the speaker and sometimes not.  I am guess the electrolytics have given out in the power supply.  I am wondering if someone has a service manual for this unit and any suggestions on what board might be the culprit.  I did see in previous posts that one or two members had the service manual but I am too new to be able to message them yet.  Any help or suggestions are appreciated.  Just in case the thing is too far gone does anyone know of the current equivalent replacement subwoofer from klipsch?

  • Like 1
Link to comment
Share on other sites

I'm not sure if I have to make a minimum number of posts or if I have to wait a period of time before I can private message members so I'm posting again to bump up the numbers.  The SW was working fine until we had a power outage at the house.  It is plugged into a UPS but the power was out for several hours and the UPS battery gave out.  I am guessing the power supply since it is not blowing the fuse which to me would indicate a power amp issue.  We'll see when I disassemble it and have a look around.

  • Like 1
Link to comment
Share on other sites

21 minutes ago, scubabuzz said:

I'm not sure if I have to make a minimum number of posts or if I have to wait a period of time before I can private message members so I'm posting again to bump up the numbers.  The SW was working fine until we had a power outage at the house.  It is plugged into a UPS but the power was out for several hours and the UPS battery gave out.  I am guessing the power supply since it is not blowing the fuse which to me would indicate a power amp issue.  We'll see when I disassemble it and have a look around.

I think you need 5 posts. (Spammer prevention)

  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

Thanks 001, the info in the link you posted is for a Monitor Audio RSW12.  I looked up that subwoofer and noticed it doesn't look anything like my Klipsch RSW-12 and I found some photos of the circuit boards and they don't look correct either.  Does anyone know if the schematics are valid for the Klipsch or are they only for the MA since I am not familiar with the MA subwoofer?  I also searched the badcaps site but didn't find any info on the Klipsch model.

Edited by scubabuzz
Link to comment
Share on other sites

9 hours ago, OO1 said:

2 subs called RSW 12 ,....my bad here 

The RSW line from Klipsch were the best they ever made (home versions) IMO for music amazing detail and "speed" plus the 12 and 15 models have quite a bit of output. The later "RT" models performed very similar but with their triangle shape and dual passives I found then much more difficult to place if a corner was not available. I never heard the Palladium but did have the Ultra 2 set and while they excelled in shear output and low end rumble they were just a tad "flabby" compared to the RSW-15. 

  • Like 2
Link to comment
Share on other sites

On 7/29/2022 at 2:23 PM, scubabuzz said:

My RSW-12 seems to have finally gave out or at least it seems the power supply has. Any help or suggestions are appreciated.  Just in case the thing is too far gone does anyone know of the current equivalent replacement subwoofer from klipsch?

 

 As stated sadly Klipsch has no equal in their current line up the RSW's were one of their last quality "hi-fi" subs they made well worth having fixed IMO if you want to stick with Klipsch brand otherwise the market has been somewhat flooded with decent to ultra high end subwoofer options from $400 to $20k+ depending on what you're trying to do.

 

 I recently had a newish Klipsch r-112sw thought it was pretty good then bought a RSL Speedwoofer 10 and it mopped it up in every way imaginable not only that the auto on feature on the Klipsch stopped working after just a couple months so I ended up sending it back. 

Link to comment
Share on other sites

Yeah, that's what I figured.  I did pick up an SPL-15 for now ant it does the job but I like the sound from my RSW-12 better.  I'm hoping to fix it and then I'll just sell the SPL-15 once I know it is working as expected.

  • Like 1
Link to comment
Share on other sites

16 hours ago, scubabuzz said:

I did find a service manual for the RW-12 on another forum.  Does anyone know if the power supply is close enough for troubleshooting purposes?

I highly doubt it completely different class of subwoofers I believe that was when they switched over to Class "D" amps for their subs. Spec sheets on both:

 

https://2d73e25b29782b6d6766-9c8af5cbfef16739445bc76457060528.ssl.cf2.rackcdn.com/RW12_635042119505880000.pdf

 

https://2d73e25b29782b6d6766-9c8af5cbfef16739445bc76457060528.ssl.cf2.rackcdn.com/RSW12_635042119380740000.pdf

Link to comment
Share on other sites

On 8/4/2022 at 5:42 PM, scubabuzz said:

 Does anyone know if the power supply is close enough for troubleshooting purposes?

 

try to locate a functional  RSW-12 ,  for troubleshooting the amplifier 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...