Jump to content

Santa Cruz and DVD's


Recommended Posts

hi, i just got a turtle beach santa cruz, and i don't think 4 speaker surround sound is working in windvd 2.4. it sounds like the back channels are the same as the front ones. i'm currently using the 4-speaker mode in the control panel (not digital 4.1 or 5.1). anyone know how to fix this?

btw, using win2k

Link to comment
Share on other sites

Hey d00d, did you have the multi channel version on WinDVD? If you don't it only supports two channel. You can either pay 50 bucks for it or go find crack for it online =) I can get ya some links if ya want or I can put them on an FTP...just let me know

Link to comment
Share on other sites

  • 1 month later...

Yo,

I have had some similar problems with WinDVD. I have the Philips Acoustic edge, but they may relate. You may actually have to enable the SP/DIF output in your general Multimedia settings (Maybe in the Santa Cruz settings for you). I did that with mine and I went from 2 channel to 5.1 just fine. Then there probably are several other settings you have to click on as 4 or 5 or 6 channel. (4.1 in your case might be seen by the computer as 5 channel, I dunno). Then, I don't know if this matters or not, try going into settings, control panel, multimedia and then click advanced properties for your preferred device (the Santa Cruz I guess.) Then set your windows speaker orientation as quadrophonic (I have 5.1 so I use surround, for example.) Hope that helps. I struggled with the same thing and now I have 5.1 so there is hope.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...