Jump to content

Dang, check out these new crown amps:


DrWho
 Share

Recommended Posts

Well I'm glad things are working out with this amp. I too would be interested in it's performance on your cornwalls. I don't think I'd ever use one for home duty, but if it performed decently there, then it should make for a good PA amp. I totally dig the idea of a built in DSP (for the more budget oriented systems).

You should repeat your frequency response tests and see if there is more roll-off compared to the last amp you were using (In fact, this would be a very accurate measurement because any effects of the mic get nullified in the difference).

OWHY do you have such slowdown when posting? I use a dual core AMD64 4800,with four GB of RAM and an ultra high speed connection the posting is slow as hell! This is ridiculous.The most lethargic forum ever. The server must be some old refurbished MacDonalds cash machine witha few old drives.I make typo upon typo here. I feel like being on a server from a large Taiwanese corporation that uploads at 4KB/sec.

Runs fine on my machine...performance isn't always about having the most expensive hardware.

Link to comment
Share on other sites

  • Replies 75
  • Created
  • Last Reply

Top Posters In This Topic

Well I'm glad things are working out with this amp. I too would be interested in it's performance on your cornwalls. I don't think I'd ever use one for home duty, but if it performed decently there, then it should make for a good PA amp. I totally dig the idea of a built in DSP (for the more budget oriented systems).

You should repeat your frequency response tests and see if there is more roll-off compared to the last amp you were using (In fact, this would be a very accurate measurement because any effects of the mic get nullified in the difference).

OWHY do you have such slowdown when posting? I use a dual core AMD64 4800,with four GB of RAM and an ultra high speed connection the posting is slow as hell! This is ridiculous.The most lethargic forum ever. The server must be some old refurbished MacDonalds cash machine witha few old drives.I make typo upon typo here. I feel like being on a server from a large Taiwanese corporation that uploads at 4KB/sec.

Runs fine on my machine...performance isn't always about having the most expensive hardware.

I don't know if or when I'll try running the Cornwalls with this amp. It's a royal PITA to get behind my stereo and make connections and move cables around. Maybe one of these days.

And if the amp sounds good, then why not use it for home duty? To me, that just doesn't make sense. It's certainly quiet enough with a S/N ratio of <105dB.

Also, I plan on doing the freq resp test again this weekend hopefully. As far as I can tell just by listening, it goes every bit as low as the last amp, but now just with a lot more power obviously.

And as for the forum, it does seem faster than the old one, but still not as fast as it should/could be. And I have a busness class cable connection. (17 mbps)

Link to comment
Share on other sites

Here's the latest. I now have the amp bridged mono, so now I'm getting 1000 watts to the sub. Surprisingly enough, the bass tightened up a bit more and seems a little deeper although the overall output is the same. Hmm...

Oh, and I also put some nice good quality rubber feet on it, so it's not sitting flat on the amp stand anymore and can't slide around.

Anyway, I took a few more pics just for fun. Go figure! [:P]

IMG_0693.jpg

IMG_0705.jpg

IMG_0698.jpg

Link to comment
Share on other sites

how does the xti compare to the qsc plx2? I wanted to get the crown for a sub and the qsc plx2 for the mains but the airflows grrrr.... You think it would be great for a rf-83 for a xti 2000?

Holy pooh! You want to feed 475 watts into each rf-83?! [:o]

One thing you may not have to worry about with the XTi 2000 on the rf-83's is that they probably won't make the amp work all that hard and the fan will never come on.

Even with my smaller XTi 1000 pulling subwoofer duty, the fan only comes on for a few brief seconds while playing very bass heavy music, and that's only at extremely loud volumes.

Link to comment
Share on other sites

oops I had a brainfart, I was thinking the XTI 2000 was the lowest model and they had the 3000 and 4000. I meant the lowest model, now that I was reminded the XTI 1000 which I believe has 275 watts (the rf-83 rms is 250 watts) which seems to be a good match. I want a high power capable amp due to me remembering the RF-7 had some crazy 2ohm impedience on the bass notes. I rather not starve my rf-83 when it comes to real bass even though with the three speakers the ohms are more controlled. Also the fan not coming is great too. I heard the QSC is alway's on though..... Now if you can hook the XTI to your cornwalls and tell me how they sound [;)] since people on this forum already spoke for the qsc plx model (deang and a few other, one even said it was better than an aragon 4004)

Edit:

I wonder why I cannot find the THD on the crown website.... QSC gives that information out.

Link to comment
Share on other sites

No, I'm just sick of all the stupidity going around. And there appears to be quite a bit of it lately. It's uncalled for and down right annoying. It's impossible to start a thread on here and keep it going peacefully without someone coming on here to screw it up.

Aren't you all tired of seeing all of these good threads turning to garbage and getting locked or deleted?! I am.

So don't come on here and try to make me out as the bad guy, saying I need to chill and whatnot. Why don't you try telling those other people to stop with their BS instead and stop ganging up on me?!

Come to think of it, the ONLY place I ever have these problems is here in the SUBWOOFER section. Go figure.

Link to comment
Share on other sites

No, I'm just sick of all the stupidity going around. And there appears to be quite a bit of it lately. It's uncalled for and down right annoying. It's impossible to start a thread on here and keep it going peacefully without someone coming on here to screw it up.

Aren't you all tired of seeing all of these good threads turning to garbage and getting locked or deleted?! I am.

So don't come on here and try to make me out as the bad guy, saying I need to chill and whatnot. Why don't you try telling those other people to stop with their BS instead and stop ganging up on me?!

Come to think of it, the ONLY place I ever have these problems is here in the SUBWOOFER section. Go figure.

Yeah, it's always the "other guys." LMAO!!!! [:'(]

http://forums.klipsch.com/forums/thread/740094.aspx

http://forums.klipsch.com/forums/thread/735246.aspx

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...