Jump to content
The Klipsch Audio Community
Sign in to follow this  
NOSValves

Woofer ID

Recommended Posts

I have a customer wondering about the originality of the woofers in his 1981 Cornwall's. Below are some pictures anyone recognize these?

post-7461-13819325228508_thumb.jpg

Share this post


Link to post
Share on other sites

Are these the Australian Cornwalls? Chris emailed me about this but I couldn't picture what he was talking about. Those look like K-33's to me. Whoever did that work is insane.

Share this post


Link to post
Share on other sites

Yup they are Chris's Cornwalls. What X-over you building him? They look like K-33's to me also.

Share this post


Link to post
Share on other sites

Have those been reconed? That looks like a pretty beginner's job on glueing the dust cap down. Either that or it came loose and someone applied some more adhesive to stick it down. It sure looks like a K33 that someone has played with a bit. Anyone have a pix of the cabinets?

Share this post


Link to post
Share on other sites

Has he measured DCR on those?  If you measure a bit less than 4 ohms, they are probably K-33s.  Measure more than 4 ohms and they are probably not K-33s or have been reconed with an 8 ohm kit.


Bob Crites

Share this post


Link to post
Share on other sites

Hi all,

These are my Cornwalls. Thanks Craig for getting the ball rolling on this, and thanks everyone for your help so far.

I bought these second hand about 8 years ago, so all the work was done by the previous owner. I knew that the speaker binding posts on the rear had been changed but was unaware of any other changes internally till a few days ago when I checked under the hood. Other than the binding posts and the woofer you are looking at, it all looks original to me, but you guys are the experts. Also, both woofers appear identical from both the front and the rear, so whatever work you see was done to both.

Bob, I haven't measured the resistance as yet, but will endeavor to so this afternoon.

I'll also try and post some more pics.

Thanks,

Chris

Share this post


Link to post
Share on other sites

It all looks good to me. Nice midriver too, kind of a rarity. I'm not sure if the 'oddity' with the dustcaps is anything to be concerned over. They have to be removed so shims can be employed to keep the cone centered in its magnetic gap while the work is being done. The posts on the frame of the driver was a good a deal of work for no real net return in performance or sonics. OTOH, it doesn't hurt anything either as long as the solder joints are good.

Share this post


Link to post
Share on other sites

I've checked the resistance of the woofers and it definitely appears to be above 4ohms. The value fluctuated between about 5 to about 10, but was definitely closer to 8ohms than 4ohms (I hope I measured it correctly, the fluctuations threw me a bit, was I doing it right?).

Having thought about this for a couple of days I now think I remember when I bought the speakers the guy also had a set of speakers similar in size to the Khorns that I now think may have been hybrids (and I'm pretty sure they weren't Khorns because I went and had a quick look at them out of curiosity), so I'm beginning to think that he may have pinched the woofers from the Cornwalls for his own speakers. Obviously I'm only going on a vague recollection, but does this sound plausible? On closer inspection I can also see that some of the screws bolting in the woofers
don't sit flush, but I've no idea if this is because it was taken out
to modify or if it's just a different woofer.

So is there any other way I can confirm/deny whether these are K-33's? If they're not then is this an issue, should I really be using K-33's? And if so, then has anyone got any suggestions on the easiest way for me to get a pair to Australia?

Thanks for all your help so far,
Chris

Share this post


Link to post
Share on other sites

The issue would be that if they are not K-33s, you don't have the woofer the Cornwall box and crossover was designed for.  So, it may work pretty good or not.  


Sounds like though that you were having lead connection problems in your measurements.  You may need to try to get a better meter or better meter leads to do that measurement again.  If you can get the measurement set-up right and consistently measure over 4 ohms, the woofers are not the right ones.

If it turns out that you really need new woofers, send me an email.

Bob Crites
bobcrites@mac.com


Share this post


Link to post
Share on other sites

I checked the measurements again and was consistently measuring around about 8ohms (still not exact, but hovering between about 7.8 and 8.3)

Bob, you have mail.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...