Jump to content
The Klipsch Audio Community

Erodr133

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Erodr133

  • Rank
    Newbie
  • Birthday 04/28/1990

Profile Information

  • Gender
    Male
  • Location
    Miami
  • My System
    Pioneer PL-117D, Kenwood KR-3130, (2) Klipsch KG 4.

Recent Profile Visitors

880 profile views
  1. Erodr133

    Forte II with Marantz 2238b

    Wow! These things are killer. They sound way better than my KG4s'. The amazing thing is that you don't really need to turn up the knob for these things to sound great! They sound sweet even at low volumes.
  2. Erodr133

    Forte II with Marantz 2238b

    I really hope so! I've heard so many great things about these speakers on different forums. It's funny, they all start with "You know I really hate horn speakers but...". I know Forte's pair really well with tube systems but I'm really happy with my Marantz. My current system now (I'm unable to edit "my system" on my profile) is a Technics SL-1400 MK1 with a Audio Technics AT440mlb, a Marantz 2238b and Klipsch KG4's. The KG4's are great value receivers but my ears prefer more detail and accuracy that I feel is lacking in the 2-way KG4's. I listen to vinyl mostly but every so often I'll plug my Fiio in and play some high rez FLAC's
  3. Hi All! So I was lucky enough to make a deal on a pair of Forte II's in my local area for a ridiculously low price. I'm picking them up tomorrow and from the pictures I've seen they are in pristine condition. I've heard nothing but great things about these speakers so I'm excited to try it out. Does anybody here have any experiences with Klipsch Forte II's with Marantz Receivers? I currently have a Marantz 2238b that I use in my system and I'm wondering if it'll pair well with the Forte's.
  4. Erodr133

    Klipsch KG 4's

    Yes, I am.
  5. Erodr133

    Klipsch KG 4's

    Hello everyone, I just bought a pair of Klipsch KG 4's and I've been having a few problems with them. I've noticed that whenever I have the bass at a reasonable level, the mid range drivers and the passive radiator in the back begin vibrating and pulsing and it is not part of the song. This is my first foray into vintage speakers so I have no idea if the crossovers are bad or something is blown. I'm hoping you folks here can help me. The speakers are running out of a Kenwood KR-3130 receiver from 1971. Any help would be greatly appreciated. Thank you!
×