Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'buyer'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 1 result

  1. Hey. I bought some second hand 2.1 promedia speakers (without subwoofer) and I have no idea how to power them on. I will attach pictures to help explain. Essentially it comes with a control pod which has a green headphone cable, and another unknown cable that kind of looks like an s link. There were then two sets of monster cables that each plug into the back of a satellite speaker respectively. I have no idea how to a) attach the two speakers together and b) turn them on. Please help. Is the subwoofer necessary to turn on the satellites? Pics: https://imgur.com/a/mSHOuRH
×
×
  • Create New...