Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags 'errors'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2019
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 1 result

  1. OK; starting a new thread to show "mistakes" made by members.Sure we have all been there and made stupid mistakes Willing to contribute to "worst mistake of the week" via PayPal. Here is my "last mistake." Bought a pair of KPT-904's ( http://assets.klipsch.com/product-specsheets/KPT-904-Data-Sheet-v04.pdf ) and WAF is about 1.0 out of 10. So; decided to take the horns "off" and build a separate box for them. Box was build ... Heritage cloth came in from Bob Crites ... made grille frames and glued on the fabric. But ... IDIOT me ... forgot to paint the grille frame black - see pic. Have made more "mistakes" hooking up equipment, etc ... Would love to see "your mistakes." Cheers, Emile
×
×
  • Create New...