Jump to content
The Klipsch Audio Community

iteched

Regulars
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

0 Neutral

About iteched

  • Rank
    Member
  1. I think its pretty neat that this particular speaker is still made today - and in the same place. Crazy cost though - $4,500 each....that is a lot of cash.
  2. Thanks for the continued recommendations. 1. Regarding using an 8 Ohm amp - It was my understanding that its best (with tube amps) to have matching impedance. Please correct me if I'm wrong. 2. I have no problems building an amp (I have several guitar pedal projects on the bench at the moment but they will be done soon). If I'm wrong with #1 above then there are many kits to choose from or just build from the above mentioned schematic. I have a friend in Garland, TX that is a tube "genius" (he has a whole house FULL of tube radios - it is NUTS what he has) that can help if I build one from scratch. 3. The current finish on mine appears to be a "golden oak" type color. However, due to YEARS of sitting in an open mechanics shop its deteriorated quite a bit. Luckily there are no rotted areas. I'm about to build a rig to hold the speaker on its back so I can start prepping it for re-finishing. I'm still debating the color. I like cherry, redwood, or perhaps a satin black. Here are some pics showing the unit right after I rescued it. You can see the years of dust buildup. I think I posted these here before about a year ago - please forgive the repost: http://i260.photobucket.com/albums/ii40/iteched/Projects/IMG_0519_zps7c1f146f.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/055_zps56013412.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/054_zps7261be60.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/052_zps5b5dbbb9.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/053_zps46df7ba1.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/056_zpsf0fb2971.jpg
  3. Brook 2A3 push-pull. That is a neat amp - and found some neat history about it. Finding one that works might be an adventure. :-)
  4. HI Guys, I'm almost done rebuilding an old 1956 Klipschorn. The crossover network is finished (old K-500-5000), the old Stevens woofer has been rebuilt....and I'm about ready to start on the woodwork. Since I only have one unit I would like to use a tube based mono amplifier to drive it. I think 5 - 15 watts should be fine. The problem I'm running into is finding a tube amp designed for 16 ohm speakers. Any recommendations? Thanks! Ed
  5. It turns out that the system is definitely 16 Ohm. The old K-500-5000 crossover has all PCB filled capacitors so they will have to be disposed of properly. I'm planning on rebuilding it with the existing coils and backing while adding modern capacitors. I'm still searching for a decent woofer replacement. I may call Klipsch to see if they offer anything at a reasonable price.
  6. I talked to Mr. Crites and he gave me a good heads up regarding the crossover capacitors. Due to their age they likely contain dangerous PCB (common to use them in caps back then) and that they should be replaced and properly disposed. I figured that as caps don't last forever anyway.
  7. With the woofer so badly deteriorated I'd like to "simply" replace it for now. Does anyone have a good recommendation? I'm currently looking at some of the "Eminence" drivers. Thanks, Ed
  8. Ok - I've performed a first clean of the cabinet. It was covered in layers of dirt and sawdust. There were many mud dauber nests that had to be removed including one in the center of the midrange. I'm sure there are more inside the cabinet but I got all I could see. Although the midrange and tweeter still play I'm sure the crossover network is compromised. There is evidence of fluid leaks around one of the capacitors. The big coils seem to be just fine, however. The woofer is in bad shape as the cone is destroyed. It will either have to be re-coned or replaced. If replacemed I'll have to find the TS parameters to match it as best as possible. I'd prefer to re-cone the old driver if at all possible. Here are some updated pics:
  9. Hmm...16 ohm input? Is that what I see on the crossover? I don't think I have any source that is more than 8 ohm.
  10. Thanks! I found that the woofer wire has been disconnected and I may start by cleaning up all the connections. There is so much dirt it will take a while to clean everything. I'll have to inspect the woofer as well to see what condition it is in. What is the ohm rating for this big guy? Cheers, Ed
  11. Thanks, The original post looks better now. Hopefully someone will chime in on restoring this speaker. Ed
  12. Sorry about the format of the above post. It looks nice in the editor but when posted everything seems to be run together. The links to the pics do work if copied and pasted into your favorite browser. Ed
  13. Hi Everyone, I've enjoyed a set of KLF-10s over the years but last night I took home an old Klipschorn (just one) speaker. It appears to be from 1956. It does play but I don't have it connected it to a source yet as its VERY DIRTY and in need of serious TLC. Please check out the pics and let me know if it is worth restoring. Some advice on care, maintenance, and what to look for would be helpful. Is there a way to test the crossover network components to see if they are still in "spec"? Here are some pics links: http://i260.photobucket.com/albums/ii40/iteched/Projects/052_zps5b5dbbb9.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/053_zps46df7ba1.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/056_zpsf0fb2971.jpg http://i260.photobucket.com/albums/ii40/iteched/Projects/054_zps7261be60.jpg I do have the midrange section cover - other than old age its still intact with the grill cloth. It does feel very dry though...afraid it may not clean up well without breaking the cloth. Thanks for any help. Ed
×
×
  • Create New...