Jump to content
The Klipsch Audio Community

yogiberra

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

3 Neutral

About yogiberra

  • Rank
    Newbie
  1. thanks for all the help. i really appreciate it.
  2. are all subs like this? it doesn't sound that good at all...do i need to adjust the gain and low pass it sounds like rumble in dance hall consuming everything? hard to adjust volume on speaker remote as well. it's either too much or not enough is there a sweet spot for location in the room that will make it better or is this as good as it gets with a $150 sub?.
  3. ty, it works i took the white and put it in sub out on my speaker......then plugged the other red/white into the sub. is it okay to have the red one hanging doing nothing
  4. so take either the red or white and put it in sub out on my speaker.......and plug the other end red/white into the sub? or this are you saying plug both the red & white dual rca cable both in my speaker left and right holes, then use only the white one going to the sub to the lfe? is it okay to only use 1 of the 2?
  5. it means when i touch one end of the rca cable while plugged it it makes a noise like like gonna work
  6. the gain and crossover were both set in the middle @ 12 clock plug included and used is the dual rca cable
  7. new set up. the powered speakers work put when i hook up the sub i get nothing. i do get power on the sub with the green light and i can hear it reverberate is the dual rca cable cord the problem? that's all that was included. i hooked them up to the sub and the right speaker (see pics) what is the problem?. do i need a different cord that goes from (sub out) on my powered speaker to lfe on the subwoofer? or do i have a lemon?
  8. new set up. the powered speakers work put when i hook up the sub i get nothing. i do get power on the sub with the green light and i can hear it reverberate is the dual rca cable cord the problem? that's all that was included i hooked them up to the sub and the right speaker (see pics) what is the problem?
×
×
  • Create New...