Jump to content
The Klipsch Audio Community

Search the Community

Showing results for tags '2.1 promedia'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Klipsch Announcements
    • Klipsch News
    • Klipsch Pilgrimage 2020
    • Klipsch Website & Forum Info
  • Klipsch Museum of Audio History
    • Klipsch Museum: News & Announcements
    • Ask the Historian
    • Klipsch Museum: General Discussion
  • Klipsch Audio
    • General Klipsch Info
    • 2-Channel Home Audio
    • Home Theater
    • Subwoofers
    • Architectural
    • Klipsch Pro Audio
    • Technical/Modifications
    • Headphones
    • Personal Music Systems
    • Talkin' Tubes
    • Solid State
  • The Klipsch Joint
    • Garage Sale
    • Lounge

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


My System


See My System


Website URL


Twitter


Skype


AIM


Yahoo


MSN


ICQ


Jabber

Found 3 results

  1. Hello, I am trying to use the two input sources on the ProMedia 2.1 speakers, but the speakers will only play one source at a time. According to the manual, plugging in both the attached 3.5mm jack and the MP3 music input should result in the two sources being mixed into one output. However, when both are plugged in at the same time, the speakers will only play from the MP3 input and play no sound from the attached 3.5mm. They each work fine on their own, but as soon as both are plugged in only the MP3 input works. Has anyone encountered this issue before or is this a known issue? Thank you for any help!
  2. Picked up a ProMedia 2.1 system yesterday at ARC thrift for $15, used to own the 5.1 when I was younger (27 now) and remember what started my love for the Klipsch sound and was devastated when the amp went but unfortunately was inexperienced back then in my early teens and had no clue why it stopped working. When I was 18 or so I owned a pair of KG 4.5s and installed the Bob Crites titanium tweeters and ended up selling them when I was around 20 and so deeply regret it every day so I picked these up figuring me being a hobbyist I'm either getting a steal or something is wrong with them and I will fix it. Brought them home, left channel dead, 3.5 input cable has a short at the connector so I have been using the AUX input, and the stock speaker wire I was able to find with it is complete garbage. Disassembled the sub unit and found left channel fuse was blown, replaced it and now that works fine. Listened all night at low volume enjoying that Klipsch sound but when I woke up I turned it up a little and noticed the left satellite mid range is blown but I did not notice the night before as I only had it at very low volume to not disturb others in the rooms next to me. I decided to upgrade the connection to the satellites by adding real binding posts and wow what a difference with some quality cables in place. Then I decided to take it a step further, I completely rewired the satellites internally with Monster XP 16 gauge partially for the fun of it as a little tribute to the actual floor standing reference line that uses similar wire and also out of curiosity of what the ending result would be. Let me tell you, just wow. Sound has opened up dramatically. Instrument separation is now completely present, and the tweeter really stands out compared to the original wiring it sounded like sound was being projected towards me, it sounded good before, but now I am floored at the difference. Very airy, open, and the clarity and accuracy is through the roof compared to before. This is the first mod I have done to these, I am going to get a replacement satellite to acquire a properly working mid range next. Then I plan to upgrade the stock aluminum cap on the satellite crossover with Dayton audio grade film caps. Also plan on replacing caps in the control module with ELNA SILMIC IIs and some caps and resistors on the amp unit as well as adding 5 way posts for the outputs on the amp to satellites. Currently have the satellites hooked up with Monster XP HP 14 gauge wire to the amp, a Sound Blaster E5 streaming Tidal master quality albums as the source and can hear such great detail I cant wait to dig in further. Some may say this is a waste of time, but for me doing it is what makes it fun for me and its the type of thing I enjoy doing! Anyway just wanted to share lol sorry for the long post hopefully someone finds it interesting!
  3. I tested the Promedia 2.1 at BB. The sub had an on/off switch and a fuse and the speakers were hard wired. What version is this? I thought the newer ones did not have the switch. There was no serial on the sub and the box sticker read Klipsch 2014. Thanks ahead of time.
×
×
  • Create New...