Jump to content

Unable to update Firmare on RW-1 wireless speaker


Recommended Posts

Hi Klipsch community,


I recently purchased RSB-14 sound bar, with 2 RW-1 Wireless speakers.

To set up a surround system with the bar and the  RW-1 speakers, you need in first place to work on some FW updates (http://assets.klipsch.com/files/Stream-Surround-Update-TechBulletin-v06.pdf)


For the RSB-14, no issue at all, you can download the binary file and use the USB interface on the bar. Worked like a charm.

However, for the RW-1 speaker you have to download the “Klipsch RW-1 Utility Stream" Update app for android or apple. And follow the steps... here start the issues.


=> The update application never find my speakers, and it stuck on the screen "Searching for device", this may take few minutes ;-D .. I let the app running for 1 hour, still did not find my speakers..


I followed every steps very carefully: wifi set up & speaker in update mode. I've also double checked my network config:


- Both speakers are seen by my network ( I can access it with their IP address on a web browser).

- I've tried DHCP IP address and then put a static IP address.. same issue

- I've tried with the speaker wired on my network: same 

- I've tried a factory reset on the speaker and start the process again. same issue

For info, the speaker in stand alone works fine on my network with the klipsch play-fi application.. I also tried to put both of it on stereo mode, and it worked great.. so my router and network set up seems to work OK..


If anyone already experienced the same issue and found how to resolve it, many thanks for sharing !



Edited by AurelP
Link to comment
Share on other sites

  • 2 weeks later...

Wondering what the solution was here, if any. Im having a similar issue with the Gate, which also is supposed to be updated via the app. I bought it and immediately the app applied 3 updates successfully. But it still says one update needs to be applied. The app sends me to the website for updating, but the website says to use the app. Anyone encountered this?

Link to comment
Share on other sites

  • 1 month later...



Same problem here. 

Klipsch Stream succesfull created the surround group (RSB14 and 2 RW1), but the sound only comes out of the bar.

The last update (MCU 0.038) didn't solved  it...


I tried to restart the system, with surround mode on the bar, changing the relative volume... but it still doesn't work 


Help !!!!

Link to comment
Share on other sites

  • 3 months later...
  • 3 months later...

While it may not solve your issues it certainly solved mine which was remarkably similar to yours.


The Utility app (on android) was completely incapable of finding the PowerGate device while the Stream app was connecting without any issues. The trick was to switch off the 3G connection on the phone and leave only wifi on. With this the Utility app connects to the device in no more than few seconds. 

Hope it helps


While the product as such is flawless the update process is terrible and I wasted hours of my life trying to get it to work. It is mildly irritating to see that a reasonably reputable company in its core business is failing to deliver a complete product at the same quality.

Link to comment
Share on other sites

  • 3 months later...

You can do it for sure. Try again follow the manual. By the way I also have RSB14 with 2-RW1s. I dont like ways to update and connection to wifi because sometime it fail and must do repeat again also seem not stable enough and quite slow connection. I ever do reset and reconnection them together again. Speakers is verygood but connection system to wifi and app should have much more development

Link to comment
Share on other sites

Moveover, i only mention from my experience. While you try to do renew connection speaker to wifi, you should do it one by one speaker and unplug all others. Another thing about RW-1, i ever did somthing wrong while upgrade firmware in app utility then unplug it. When plug and found that there no any light at top panel, only blink green light at back. It made me feel bad until i read manual and start steps all again until it work as it should.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...